您的位置:首页 > 其它

POJ 1328 Radar Installation

2015-07-21 20:00 399 查看
Radar Installation

Time Limit:1000MS Memory Limit:10000K

Total Submit:55 Accepted:18

Description

Assume the coasting is an infinite straight line. Land is in one side of coasting, sea in the other. Each small island is a point locating in the sea side. And any radar installation, locating on the
coasting, can only cover d distance, so an island in the sea can be covered by a radius installation, if the distance between them is at most d.

We use Cartesian coordinate system, defining the coasting is the x-axis. The sea side is above x-axis, and the land side below. Given the position of each island in the sea, and given the distance of the coverage of the radar installation, your task is to write
a program to find the minimal number of radar installations to cover all the islands. Note that the position of an island is represented by its x-y coordinates.



Figure A Sample Input of Radar Installations

Input

The input consists of several test cases. The first line of each case contains two integers n (1<=n<=1000) and d, where n is the number of islands in the sea and d is the distance of coverage of the radar installation. This is followed
by n lines each containing two integers representing the coordinate of the position of each island. Then a blank line follows to separate the cases.

The input is terminated by a line containing pair of zeros

Output

For each test case output one line consisting of the test case number followed by the minimal number of radar installations needed. "-1" installation means no solution for that case.

Sample Input

3 2
1 2
-3 1
2 1

1 2
0 2

0 0


Sample Output

Case 1: 2
Case 2: 1思路:若一小岛可被雷达探测到,那么这个雷达可放置范围在左端点x-sqrt(d*d-y*y)和右端点x*x+sqrt(d*d-y*y)这一区间之间,根据所有小岛的左端点进行升序排序,然后将雷达放置在第一个区间的右端点k,如果第二个区间的左端点大于k,说明需要多添一个雷达(此雷达放置在第二个区间的右端点上);若第二个区间的右端点小于k,那么雷达的位置变为第二个区间的右端点(这样可以覆盖该区间的小岛),然后继续探索第三个区间,依次类推
代码如下:
[code]1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37
#include <cstdio>
#include <cmath>
#include <algorithm>
using namespace std;
#define M 1005
struct pos{
double x, y, l, r;
}p[M];
bool cmp(pos a, pos b)
{ return a.l < b.l; }
int main()
{
int n, d, i, j, c = 1;
while(~scanf("%d%d",&n,&d)){
if(n == 0 && d == 0) break;
int ans = 0;
for(i = 0; i < n; i++){
scanf("%lf%lf",&p[i].x,&p[i].y);
if(p[i].y > d) ans = -1;
p[i].l = p[i].x-sqrt(d*d-p[i].y*p[i].y);
p[i].r = p[i].x+sqrt(d*d-p[i].y*p[i].y);
}
if(ans != -1)
{
sort(p, p+n, cmp);
double k = p[0].r;
ans = 1;
for(i = 1; i < n; i++)
if(p[i].l > k){
ans++;
k = p[i].r;
}
else if(p[i].r < k)  k = p[i].r;
}
printf("Case %d: %d\n",c++,ans);
}
}
[/code]
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: