您的位置:首页 > 其它

嘻唰唰第六批Problem G: B 求类中数据成员的最大值-类模板

2015-07-21 18:46 363 查看

Description

声明一个类模板,类模板中有三个相同类型的数据成员,有一函数来获取这三个数据成员的最大值。

类模板声明如下:

template<class numtype>

class Max

{

public:

Max(numtype a,numtype b,numtype c);

numtype getMax();

private:

numtype x,y,z;

};

请在下面的程序段基础上完成整个设计:

#include <iostream>

#include <iomanip>

using namespace std;

template<class numtype>

class Max

{

public:

Max(numtype a,numtype b,numtype c);

numtype getMax();

private:

numtype x,y,z;

};

//将程序需要的其他成份写在下面,只提交begin到end部分的代码

//******************** begin ********************

//********************* end ********************

int main()

{

int i1,i2,i3;

cin>>i1>>i2>>i3;

Max<int> max1(i1,i2,i3);

cout<<max1.getMax()<<endl;

float f1,f2,f3;

cin>>f1>>f2>>f3;

Max<float> max2(f1,f2,f3);

cout<<setiosflags(ios::fixed);

cout<<setprecision(2);

cout<<max2.getMax()<<endl;

char c1,c2,c3;

cin>>c1>>c2>>c3;

Max<char> max3(c1,c2,c3);

cout<<max3.getMax()<<endl;

return 0;

}

Input

分别输入3个整数,3个浮点数,3个字符

Output

3个整数的最大值

3个浮点数中的最大值

3个字符中的最大值

Sample Input

9 5 6
1.1 3.4 0.9
a b c

Sample Output

9
3.40
c


代码;

#include <iostream>
#include <iomanip>
using namespace std;

template<class numtype>

class Max
{

public:

Max(numtype a,numtype b,numtype c);

numtype getMax();

private:

numtype x,y,z;

};template<class numtype>
Max<numtype>::Max(numtype a,numtype b,numtype c):x(a),y(b),z(c) {}

template<class numtype>
numtype Max<numtype>::getMax()
{
numtype max;
max=x;
if(max<y)

max=y;
if(max<z)
max=z;

return max;

}
int main()
{

int i1,i2,i3;

cin>>i1>>i2>>i3;

Max<int> max1(i1,i2,i3);

cout<<max1.getMax()<<endl;

float f1,f2,f3;

cin>>f1>>f2>>f3;

Max<float> max2(f1,f2,f3);

cout<<setiosflags(ios::fixed);

cout<<setprecision(2);

cout<<max2.getMax()<<endl;

char c1,c2,c3;

cin>>c1>>c2>>c3;

Max<char> max3(c1,c2,c3);

cout<<max3.getMax()<<endl;

return 0;

}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: