您的位置:首页 > 其它

HDU 1064 && ZOJ 1048 Financial Management【水】

2015-07-21 09:46 274 查看
ZOJ Problem Set - 1048

Financial Management
Time Limit: 2 Seconds     
Memory Limit: 65536 KB



Larry graduated this year and finally has a job. He's making a lot of money, but somehow never seems to have enough. Larry has decided that he needs to grab hold of his financial portfolio and solve his financing problems. The first step is to figure out
what's been going on with his money. Larry has his bank account statements and wants to see how much money he has. Help Larry by writing a program to take his closing balance from each of the past twelve months and calculate his average account balance.

Input Format:

The input will be twelve lines. Each line will contain the closing balance of his bank account for a particular month. Each number will be positive and displayed to the penny. No dollar sign will be included.

Output Format:

The output will be a single number, the average (mean) of the closing balances for the twelve months. It will be rounded to the nearest penny, preceded immediately by a dollar sign, and followed by the end-of-line. There will be no other spaces or characters
in the output.

Sample Input:

100.00

489.12

12454.12

1234.10

823.05

109.20

5.27

1542.25

839.18

83.99

1295.01

1.75

Sample Output:

$1581.42 

题意:

给出一个人每个月花的钱,然后求出这个人平均月消费。

这个比较简单,只需要累加求和,输出时求平均就行.....

#include<stdio.h>
int main()
{
int i;double s,x;
while(~scanf("%lf",&x))
{
s=x;
for(i=1;i<12;++i)
{
scanf("%lf",&x);
s+=x;
}
printf("$%.2lf\n",s/12);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: