您的位置:首页 > 运维架构

POJ 3258 River Hopscotch

2015-07-20 21:34 295 查看
River Hopscotch
Time Limit:2000MS Memory Limit:65536KB 64bit IO Format:%I64d
& %I64u
Submit Status Practice POJ
3258

Appoint description:
System Crawler (2015-07-18)

Description

Every year the cows hold an event featuring a peculiar version of hopscotch that involves carefully jumping from rock to rock in a river. The excitement takes place on a long, straight river with a rock at the start and another rock at the end, L units
away from the start (1 ≤ L ≤ 1,000,000,000). Along the river between the starting and ending rocks, N (0 ≤ N ≤ 50,000) more rocks appear, each at an integral distance Di from the start (0 < Di < L).

To play the game, each cow in turn starts at the starting rock and tries to reach the finish at the ending rock, jumping only from rock to rock. Of course, less agile cows never make it to the final rock, ending up instead in the river.

Farmer John is proud of his cows and watches this event each year. But as time goes by, he tires of watching the timid cows of the other farmers limp across the short distances between rocks placed too closely together. He plans to remove several rocks in
order to increase the shortest distance a cow will have to jump to reach the end. He knows he cannot remove the starting and ending rocks, but he calculates that he has enough resources to remove up toM rocks (0 ≤ M ≤ N).

FJ wants to know exactly how much he can increase the shortest distance *before* he starts removing the rocks. Help Farmer John determine the greatest possible shortest distance a cow has to jump after removing the optimal set of M rocks.

Input

Line 1: Three space-separated integers: L, N, and M

Lines 2.. N+1: Each line contains a single integer indicating how far some rock is away from the starting rock. No two rocks share the same position.

Output

Line 1: A single integer that is the maximum of the shortest distance a cow has to jump after removing M rocks

Sample Input

25 5 2
2
14
11
21
17


Sample Output

4


Hint

Before removing any rocks, the shortest jump was a jump of 2 from 0 (the start) to 2. After removing the rocks at 2 and 14, the shortest required jump is a jump of 4 (from 17 to 21 or from 21 to 25).

思路: n高达50000, 肯定不可能是暴力枚举。我们用一个“猜”的思想,先猜这个值可以是多少,再用一个函数验证。

然后利用单调性,注意单调性是必须,不然无法进行二分搜索,猜的值满足条件,说明还可以再变小,继续二分下去。

其实这和牛顿的二分求方程的跟的思路是一样的。

#include<iostream>
#include<cstdio>
#include<algorithm>
#include<cstring>
using namespace std;
#define maxn 50005
#define inf 0x3f3f3f3f
int a[maxn];
int l,n,m;
bool c(int x){
int temp=0;
int sum=0;
for(int i=0;i<=n;i++){
if(a[i]-temp<x){
sum++;
}
else{
temp=a[i];
}
if(sum>m)return false;
}
return true;
}
int main()
{
//freopen("in.txt","r",stdin);
while(~scanf("%d%d%d",&l,&n,&m)){
for(int i=0;i<n;i++){
scanf("%d",&a[i]);
}
sort(a,a+n);
a
=l;
/*
if(n==m){
printf("%d\n",l);
continue;
}*/
int ua=0;
int ub=l+1;      //注意到这种n==m这种情况,这是是取l,所以ub必须大于l,不然就取不到
while(ub-ua>1){
int mid=(ub+ua)>>1;
if(c(mid))ua=mid;
else ub=mid;
}
printf("%d\n",ua);
}
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: