您的位置:首页 > 其它

TEX Quotes

2015-07-20 18:51 330 查看
TEX
Quotes
Time Limit:3000MS Memory Limit:0KB 64bit IO Format:%lld
& %llu

Description

TeX is a typesetting language developed by Donald
Knuth. It takes source text together with a few typesetting instructions and produces, one hopes, a beautiful document. Beautiful documents use `` and " to delimit quotations, rather than the mundane
" which is what is provided by most keyboards. Keyboards typically do not have an oriented double-quote, but they do have a left-single-quote
` and a right-single-quote '. Check your keyboard now to locate the left-single-quote key
` (sometimes called the ``backquote key") and the right-single-quote key
' (sometimes called the ``apostrophe" or just ``quote"). Be careful not to confuse the left-single-quote
` with the ``backslash" key
\
. TeX lets the user type two left-single-quotes
`` to create a left-double-quote `` and two right-single-quotes '' to create a right-double-quote ''. Most typists, however, are accustomed to delimiting their quotations with the un-oriented double-quote
".

If the source contained

"To be or not to be," quoth the bard, "that is the question."

then the typeset document produced by TeX would not contain the desired form:

``To be or not to be," quoth the bard, ``that is the question."

In order to produce the desired form, the source file must contain the sequence:

``To be or not to be,'' quoth the bard, ``that is the question.''

You are to write a program which converts text containing double-quote (") characters into text that is identical except that double-quotes have been replaced by the two-character sequences required by
TeX for delimiting quotations with oriented double-quotes. The double-quote (") characters should be replaced appropriately by either
`` if the " opens a quotation and by '' if the " closes a quotation. Notice that the question of nested quotations does not arise: The first
" must be replaced by ``, the next by '', the next by
``, the next by '', the next by ``, the next
by '', and so on.

Input

Input will consist of several lines of text containing an even number of double-quote (") characters. Input is ended with an end-of-file character.

Output

The text must be output exactly as it was input except that:

the first " in each pair is replaced by two ` characters: `` and
the second " in each pair is replaced by two ' characters: ''.

Sample Input

"To be or not to be," quoth the Bard, "that
is the question".
The programming contestant replied: "I must disagree.
To `C' or not to `C', that is The Question!"


Sample Output

``To be or not to be,'' quoth the Bard, ``that
is the question''.
The programming contestant replied: ``I must disagree.
To `C' or not to `C', that is The Question!''


题目的大概意思:在TeX中,左引号是' "
' 将其转化为' `` ',右引号' " ' 将其转化为' '' ';将整篇文章中的引号 转换后输出文章。

这道题主要是输入和判断引号,不能用scanf("%s", s);输入,这样输入是要读取空格的,而且不知道文章中有多少空格,直接输入全部TeX然后再遍历判断是很费事的,因此通过单个字符的输入然后依次判断比较省时,代码的效率跟高些。

代码:
#include <stdio.h>

int main()

{

int c, t=1;

while((c = getchar())!=EOF)

{

if(c == '"')

{

printf("%s", t ? "``" : "``" );

t=!t;

}

else

printf("%c", c);

}

return 0;

}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: