您的位置:首页 > 产品设计 > UI/UE

POJ 2259 --- Team Queue

2015-07-20 10:18 671 查看
Team Queue

Time Limit: 2000MSMemory Limit: 65536K
Total Submissions: 2679Accepted: 1015
Description

Queues and Priority Queues are data structures which are known to most computer scientists. The Team Queue, however, is not so well known, though it occurs often in everyday life. At lunch time the queue in front of the Mensa is a team queue, for example.

In a team queue each element belongs to a team. If an element enters the queue, it first searches the queue from head to tail to check if some of its teammates (elements of the same team) are already in the queue. If yes, it enters the queue right behind them.
If not, it enters the queue at the tail and becomes the new last element (bad luck). Dequeuing is done like in normal queues: elements are processed from head to tail in the order they appear in the team queue.

Your task is to write a program that simulates such a team queue.
Input

The input will contain one or more test cases. Each test case begins with the number of teams t (1<=t<=1000). Then t team descriptions follow, each one consisting of the number of elements belonging to the team and the elements themselves. Elements are integers
in the range 0 - 999999. A team may consist of up to 1000 elements.

Finally, a list of commands follows. There are three different kinds of commands:

ENQUEUE x - enter element x into the team queue

DEQUEUE - process the first element and remove it from the queue

STOP - end of test case

The input will be terminated by a value of 0 for t.

Warning: A test case may contain up to 200000 (two hundred thousand) commands, so the implementation of the team queue should be efficient: both enqueing and dequeuing of an element should only take constant time.
Output

For each test case, first print a line saying "Scenario #k", where k is the number of the test case. Then, for each DEQUEUE command, print the element which is dequeued on a single line. Print a blank line after each test case, even after the last one.

Sample Input
2
3 101 102 103
3 201 202 203
ENQUEUE 101
ENQUEUE 201
ENQUEUE 102
ENQUEUE 202
ENQUEUE 103
ENQUEUE 203
DEQUEUE
DEQUEUE
DEQUEUE
DEQUEUE
DEQUEUE
DEQUEUE
STOP
2
5 259001 259002 259003 259004 259005
6 260001 260002 260003 260004 260005 260006
ENQUEUE 259001
ENQUEUE 260001
ENQUEUE 259002
ENQUEUE 259003
ENQUEUE 259004
ENQUEUE 259005
DEQUEUE
DEQUEUE
ENQUEUE 260002
ENQUEUE 260003
DEQUEUE
DEQUEUE
DEQUEUE
DEQUEUE
STOP
0

Sample Output
Scenario #1
101
102
103
201
202
203

Scenario #2
259001
259002
259003
259004
259005
260001

Source

Ulm Local 1998

题意简介

在组队队列中,每个元素(element)属于一支队伍。如果一个元素将要进入组队队列时,他会从头到尾检查它的队友(同属于一支队伍)是否已经在队列中,如果找到了,他就会紧随其后进入队伍。如果没有找到,则它会从队列末尾入队,并成为自己队伍的第一个元素。出队操作则跟普通队列一样:元素在组队队列中按从头到尾的顺序出列。就像要排一支很长的队伍,但是不想从最后面排起,于是就会从头到尾看看队伍中有没有熟人在,如果有,就插队到熟人后面;如果没有,就只能从队尾慢慢排了。

思路

这题主要解决入队问题,如果只用一个队列表示team queue模拟的话,则在入队时会花费很多时间。因此用team个队列来表示team queue,再用一个队列来保存team前后的信息,然后加上一个flag来判断team是否有element在team queue中。

代码

(一)书上代码

#include <iostream>
#include <string>
#include <queue>
#include <map>
using namespace std;
int nCaseNum,nNum;   //Case数、总控制数
queue < long > nQue[1001];   //存储每个队列
queue < int > nS;   //存储队列号
int nM[1000000];   //元素与队列号的映射表
bool nFlag[1001];   //标识有无同组元素

void solve()   //
{
string nCommand;
long nElem;
cout<<"Scenario #"<<++nCaseNum<<endl;  //输出第几个
while (cin>>nCommand,nCommand!="STOP")   //判断输入的字符串是否不是"STOP"
{
if (nCommand == "ENQUEUE")   //判断字符串 "ENQUEUE"
{
cin>>nElem;   //输入元素
if (!nFlag[nM[nElem]])   //若还没有同组元素
{
nFlag[nM[nElem]] = true;
nS.push(nM[nElem]);   //将组号进队列
}
nQue[nM[nElem]].push(nElem);
}
else if (nCommand == "DEQUEUE")  //判断字符串 "DEQUEUE"
{
int nId=nS.front();   //首先处理最先进队列的那组元素
cout<<nQue[nId].front()<<endl;   //输出值
nQue[nId].pop();   //压出队列
if (nQue[nId].empty())   //判断队列是否为空
{
nS.pop();
nFlag[nId] = false;
}
}
}
cout<<endl;
}

void init ()   //初始化很重要
{
for (int i=0;i!=nNum;i++)  //清空队列nQue
{
nFlag[i]=false;
while (!nQue[i].empty())    nQue[i].pop();
}
while (!nS.empty()) nS.pop();  //清空队列号nS
}

void input()  //输入函数
{
int nElem,elemNum;
for (int i=0;i<nNum;i++)
{
cin>>elemNum;   //输入元素个数
for (int j=0;j!=elemNum;j++)   //循环,输入元素
{
cin>>nElem;
nM[nElem] = i;
}
}
}

int main ()   //主函数
{
nCaseNum=0;
while (cin>>nNum,nNum)
{
init();
input();
solve();
}
return 0;
}


结果

内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: