您的位置:首页 > 产品设计 > UI/UE

Number Sequence

2015-07-19 13:11 381 查看


Number Sequence




Time Limit: 1000ms   Memory limit: 65536K  有疑问?点这里^_^



题目描述

A number sequence is defined as follows: 

f(1) = 1, f(2) = 1, f(n) = (A * f(n - 1) + B * f(n - 2)) mod 7. 

Given A, B, and n, you are to calculate the value of f(n).


输入

The input consists of multiple test cases. Each test case contains 3 integers A, B and n on a single line (1 <= A, B <= 1000, 1 <= n <= 100,000,000). Three zeros signal the end of input and this test case is not to be processed.


输出

For each test case, print the value of f(n) on a single line.


示例输入

1 1 3
1 2 10
0 0 0



示例输出

2
5



提示

知识扩展:本类算法在数字医疗、移动证券、手机彩票、益智类解谜类游戏软件中会经常采用。


来源

 


示例程序

矩阵快速幂!唉,事后听了大神的一般数很大又取莫之类的,都是有些思维题;
#include <iostream>
#include<cstdio>
#include<cstring>
#include<algorithm>
#include<queue>
#include<stack>
#include<cmath>
using namespace std;
void solve(int a,int b,int n)
{
int ans_1=1,ans_2=1,c=1,d=0;
int tmp,w,x,y,z;
n-=2;
while(n)
{
if(n&1)
{
tmp=ans_1;
ans_1=(ans_1*a%7+ans_2*b%7)%7;
ans_2=tmp*c+ans_2*d;
}
w=a;x=b;y=c;z=d;
a=(w*w+y*x)%7;
c=(w*y+y*z)%7;
b=(w*x+x*z)%7;
d=(x*y+z*z)%7;
n>>=1;
}
printf("%d\n",ans_1);
}
int main()
{
int a,b,n;
while(~scanf("%d%d%d",&a,&b,&n)&&(a||b||n))
{
if(n<=2)
{
printf("1\n");
continue;
}
solve(a,b,n);
}
return 0;
}


 
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: