您的位置:首页 > 其它

poj 1469 COURSES 二分图最大匹配 匈牙利算法

2015-07-17 13:42 309 查看
COURSES

Time Limit: 1000MSMemory Limit: 10000K
Total Submissions: 19081Accepted: 7520
Description
Consider a group of N students and P courses. Each student visits zero, one or more than one courses. Your task is to determine whether it is possible to form a committee of exactly P students that satisfies simultaneously the
conditions:

every student in the committee represents a different course (a student can represent a course if he/she visits that course)

each course has a representative in the committee

Input
Your program should read sets of data from the std input. The first line of the input contains the number of the data sets. Each data set is presented in the following format:

P N

Count1 Student1 1 Student1 2 ... Student1 Count1

Count2 Student2 1 Student2 2 ... Student2 Count2

...

CountP StudentP 1 StudentP 2 ... StudentP CountP

The first line in each data set contains two positive integers separated by one blank: P (1 <= P <= 100) - the number of courses and N (1 <= N <= 300) - the number of students. The next P lines describe in sequence of the courses �from course 1 to course P,
each line describing a course. The description of course i is a line that starts with an integer Count i (0 <= Count i <= N) representing the number of students visiting course i. Next, after a blank, you抣l find the Count i students, visiting the course, each
two consecutive separated by one blank. Students are numbered with the positive integers from 1 to N.

There are no blank lines between consecutive sets of data. Input data are correct.

Output
The result of the program is on the standard output. For each input data set the program prints on a single line "YES" if it is possible to form a committee and "NO" otherwise. There should not be any leading blanks at the start
of the line.
Sample Input
2
3 3
3 1 2 3
2 1 2
1 1
3 3
2 1 3
2 1 3
1 1

Sample Output
YES
NO

Source
Southeastern Europe 2000

有p门课程,n个学生,要求每个学生都要有一门课程,每门课程至少一个学生,能达到要求输出yes,否则输出no;

匈牙利算法,用的是邻接表实现的,

#include<map>
#include<vector>
#include<cstdio>
#include<iostream>
#include<cstring>
#include<string>
#include<algorithm>
#include<cmath>
#include<stack>
#include<queue>
#include<set>
#define inf 0x3f3f3f3f
#define mem(a,x) memset(a,x,sizeof(a))

using namespace std;

typedef long long ll;
typedef pair<int,int> pii;

inline int in()
{
int res=0;char c;
while((c=getchar())<'0' || c>'9');
while(c>='0' && c<='9')res=res*10+c-'0',c=getchar();
return res;
}

vector<int> v[333];
int vis[333];
int match[333];
int n,p;
int flag;
bool dfs(int x)
{
for(int i=0;i<v[x].size();i++)
{
if(vis[v[x][i]]!=flag)
{
vis[v[x][i]]=flag;
if(match[v[x][i]]==-1 || dfs(match[v[x][i]])) // 未被匹配或者已经匹配,但是从这点出发还能找到增路
{
match[v[x][i]]=x;                        //记录是x匹配的v[x][i]
return 1;
}
}
}
return 0;
}

int main()
{
int t;
cin>>t;
while(t--)
{

p=in();//kecheng
n=in();//xuesheng

for(int i=0;i<=330;i++)v[i].clear();
for(int i=1;i<=p;i++)
{
int tmp=in();
while(tmp--)
{
int t2=in();
v[i].push_back(t2);
}

}

int ans=0;
mem(match,-1);
mem(vis,0);
for(int i=1;i<=p;i++)
{
flag=i;                //避免每次初始化
if(dfs(i)) ans++;

}

puts(ans==p?"YES":"NO");//课程都需要被匹配
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: