您的位置:首页 > 其它

poj1050To the Max

2015-07-14 09:02 225 查看
Description

Given a two-dimensional array of positive and negative integers, a sub-rectangle is any contiguous sub-array of size 1*1 or greater located within the whole array. The sum of a rectangle is the sum of all the elements in that rectangle. In this problem the
sub-rectangle with the largest sum is referred to as the maximal sub-rectangle.

As an example, the maximal sub-rectangle of the array:

0 -2 -7 0

9 2 -6 2

-4 1 -4 1

-1 8 0 -2

is in the lower left corner:

9 2

-4 1

-1 8

and has a sum of 15.

Input

The input consists of an N * N array of integers. The input begins with a single positive integer N on a line by itself, indicating the size of the square two-dimensional array. This is followed by N^2 integers separated by whitespace (spaces and newlines).
These are the N^2 integers of the array, presented in row-major order. That is, all numbers in the first row, left to right, then all numbers in the second row, left to right, etc. N may be as large as 100. The numbers in the array will be in the range [-127,127].
Output

Output the sum of the maximal sub-rectangle.
Sample Input
4
0 -2 -7 0 9 2 -6 2
-4 1 -4  1 -1

8  0 -2

Sample Output
15

Source
题意:求最大子矩阵使得和最大。
思路:一维的连续和可以在O(n)的时间内求出(前缀和或者动态规划等),所以我们只要能把二维变成一维就好了,通过枚举上下边O(n*n),我们可以得到上下边之间的每一列的和,然后就变成一维了,总时间复杂度就是O(n*n*n).
#include <iostream>
#include <stdio.h>
#include <cstring>
#include <algorithm>
#include <queue>
#include <map>
using namespace std;
const int MAXN = 110;
int n;
int sum[MAXN][MAXN];//对每一列求和,方便在O(1)的时间复杂度算出上下边之间每一列的和
int sum1[MAXN]; //压缩为一维保存
int main()
{
int i, j, k;
while(scanf("%d",&n)!=EOF)
{
memset(sum[0],0,sizeof sum[0]);
for(i=1; i<=n; i++)
{
for(j=1; j<=n; j++)
{
scanf("%d",&sum[i][j]);
sum[i][j] += sum[i-1][j];
}
}
int ans = sum[1][1];
for(i=0; i<n; i++) //枚举上边
{
for(j=i+1; j<=n; j++) //枚举下边
{
/*
//前缀和
sum1[0] = 0;
for(k=1; k<=n; k++)
{
sum1[k] = sum[j][k] - sum[i][k];
sum1[k] += sum1[k-1];
}
int min1 = 0;
for(k=1; k<=n; k++)
{
ans = max(ans, sum1[k]-min1);
min1 = min(min1, sum1[k]);
}*/
//求一维还可以动态规划
sum1[0] = 0;
for(k=1; k<=n; k++)
{
sum1[k] = sum[j][k] - sum[i][k];
sum1[k] = max(0,sum1[k-1]) + sum1[k];
ans = max(ans,sum1[k]);
}
}
}
printf("%d\n", ans);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: