您的位置:首页 > 产品设计 > UI/UE

The Unique MST(次小生成树)

2015-07-11 13:48 246 查看
The Unique MST

Time Limit: 1000MSMemory Limit: 10000K
Total Submissions: 22899Accepted: 8147
Description

Given a connected undirected graph, tell if its minimum spanning tree is unique.

Definition 1 (Spanning Tree): Consider a connected, undirected graph G = (V, E). A spanning tree of G is a subgraph of G, say T = (V', E'), with the following properties:

1. V' = V.

2. T is connected and acyclic.

Definition 2 (Minimum Spanning Tree): Consider an edge-weighted, connected, undirected graph G = (V, E). The minimum spanning tree T = (V, E') of G is the spanning tree that has the smallest total cost. The total cost of T means the sum of the weights on all
the edges in E'.

Input

The first line contains a single integer t (1 <= t <= 20), the number of test cases. Each case represents a graph. It begins with a line containing two integers n and m (1 <= n <= 100), the number of nodes and edges. Each of the following m lines contains a
triple (xi, yi, wi), indicating that xi and yi are connected by an edge with weight = wi. For any two nodes, there is at most one edge connecting them.
Output

For each input, if the MST is unique, print the total cost of it, or otherwise print the string 'Not Unique!'.
Sample Input
2
3 3
1 2 1
2 3 2
3 1 3
4 4
1 2 2
2 3 2
3 4 2
4 1 2

Sample Output
3
Not Unique!

Source
这一题跟上面那道题一样,只是这里如果不一样,让你输出最小生成树的值!

#include<cstdio>
#include<iostream>
#include<cstring>
const int infinity=0x3f3f3f3f;
const int maxnum=120;
using namespace std;
int nodenum,result;
int map1[maxnum][maxnum],visited[maxnum],low[maxnum];//最小生成树基本变量
int mmax[maxnum][maxnum],pre[maxnum],connect[maxnum][maxnum];//次小生成树必须变量
void prim()
{
    int i,j,Min,pos=1,fa;
    result=0;
    memset(visited,0,sizeof(visited));//初始化都未标记
    memset(mmax,0,sizeof(mmax));//*****mmax初始化为0*****
    for(i=1;i<=nodenum;i++)
    {
        low[i]=map1[pos][i];
        pre[i]=pos;//*****把所有的点的前节点记录为1*****
    }
    low[pos]=0;
    visited[pos]=1;//把1号作为起点
    for(i=2;i<=nodenum;i++)//这个i没有其他的意思就是一个循环次数
    {
        Min=infinity;pos=-1;//从1号开始找最小的边
        for(j=1;j<=nodenum;j++)
        {
            if(!visited[j]&&Min>low[j])
            {
                Min=low[j];
                pos=j;
            }
        }
        if(pos==-1)
        {
            return ;
        }
        visited[pos]=1;//做到与1os号最近的边
        result+=Min;//加权值
        fa=pre[pos];//*****取得这个点的前节点*****
        connect[fa][pos]=connect[pos][fa]=0;//*****让前节点与当前点不是联通的!
        mmax[fa][pos]=Min;//*****设置前点与当前点的距离为Min*****
        for(j=1;j<=nodenum;j++)
        {
            if(!visited[j]&&low[j]>map1[pos][j])
            {
                low[j]=map1[pos][j];//这个就是替换未被标记的最小权值!
                pre[j]=pos;//*****更新此时所有被更换权值节点的前节点为pos*****
            }
        }
        //*****以下为次小生成树新增*****
        for(j=1;j<=nodenum;j++)
        {
            mmax[j][pos]=mmax[fa][pos]>mmax[j][fa]?mmax[fa][pos]:mmax[j][fa];//更新次小权值
        }
        //*****以上为次小生成树新增*****
    }
    return ;
}
int main()
{
    int t,m,i,j,a,b,c,flag;
    cin>>t;
    while(t--)
    {
        memset(map1,infinity,sizeof(map1));
    /*   for(i=1;i<=nodenum;i++)
       {
           for(j=1;j<=nodenum;j++)
           {
               map1[i][j]=infinity;
           }
       }把这个替换成上面那个就WA了不知道为什么,以后注意一点!
       */
        memset(connect,0,sizeof(connect));//*****
        cin>>nodenum>>m;
        while(m--)
        {
            cin>>a>>b>>c;
            if(c<map1[a][b])
            {
                map1[a][b]=map1[b][a]=c;
                connect[a][b]=connect[b][a]=1;//*****
            }
        }
        prim();
        flag=0;
        for(i=1;i<=nodenum;i++)
        {
            for(j=1;j<=nodenum;j++)
            {
                if(connect[i][j]==0||map1[i][j]==infinity)
                {
                    continue;
                }
                if(map1[i][j]==mmax[i][j])
                {
                    flag++;
                }
            }
        }
       if(flag==0)
       {
           cout<<result<<endl;
       }
       else
       {
           cout<<"Not Unique!"<<endl;
       }
    }
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: