您的位置:首页 > 其它

1006. Sign In and Sign Out (25)

2015-07-08 15:46 399 查看


1006. Sign In and Sign Out (25)

时间限制

400 ms

内存限制

65536 kB

代码长度限制

16000 B

判题程序

Standard

作者

CHEN, Yue

At the beginning of every day, the first person who signs in the computer room will unlock the door, and the last one who signs out will lock the door. Given the records of signing in's and out's, you are supposed to find the ones who have unlocked and locked
the door on that day.

Input Specification:

Each input file contains one test case. Each case contains the records for one day. The case starts with a positive integer M, which is the total number of records, followed by M lines, each in the format:
ID_number Sign_in_time Sign_out_time


where times are given in the format HH:MM:SS, and ID number is a string with no more than 15 characters.

Output Specification:

For each test case, output in one line the ID numbers of the persons who have unlocked and locked the door on that day. The two ID numbers must be separated by one space.

Note: It is guaranteed that the records are consistent. That is, the sign in time must be earlier than the sign out time for each person, and there are no two persons sign in or out at the same moment.
Sample Input:
3
CS301111 15:30:28 17:00:10
SC3021234 08:00:00 11:25:25
CS301133 21:45:00 21:58:40

Sample Output:
SC3021234 CS301133

这题思路很简单,只需要两个变量存放最早时间和最晚时间,再用两个变量存放对应ID,维护这四个变量的值就可以了。用户输入一个,就更新一遍对应的四个变量的值,最后输出对应的ID值即可

#include<vector>
#include <sstream>
#include<cmath>
#include<iomanip>
#include<iostream>
#include <ctype.h>
#include <stdlib.h>
#include <algorithm>

using namespace std;
struct Time
{
int hour;
int min;
int sec;
};

Time StringToTime(string s)//实现将字符串转化为对应的时间格式
{
Time time;
string hour = s.substr(0, 2);
string min = s.substr(3,2);
string sec = s.substr(6,2);
time.hour = atoi(hour.c_str());
time.min = atoi(min.c_str());
time.sec = atoi(sec.c_str());
return time;
}

Time EarlyTime(Time time1, Time time2)//判断两个时间,返回较早的时间
{
if (time1.hour < time2.hour)
{
return time1;
}
else if (time1.hour > time2.hour)
{
return time2;
}
else//如果小时相同,则继续判断分钟的情况
{
if (time1.min < time2.min)
{
return time1;
}
else if (time1.min > time2.min)
{
return time2;
}
else
{
if (time1.sec < time2.sec)
{
return time1;
}
else
{
return time2;
}
}
}

}

int main()
{
string personID[2];
int n;
cin >> n;
string timei, timeo;
Time ftime, ltime;

string fpersonID,lpersonID;

for (int i = 0; i < n; i++)
{
string ID;
cin >> ID;
cin >> timei >> timeo;
Time time_in, time_out;
time_in = StringToTime(timei);
time_out = StringToTime(timeo);
if (i == 0)
{
ftime = time_in;
ltime = time_out;
fpersonID = ID;
lpersonID = ID;//为最早最晚时间赋初值
}
else
{
ftime = EarlyTime(time_in, ftime);//如果目前的最早时间就是当前这次输入的时间
if ((ftime.hour == time_in.hour) && (ftime.min == time_in.min) && (ftime.sec == time_in.sec))
{
fpersonID = ID;//修改ID和对应的最早时间点
}

Time temp = EarlyTime(time_out, ltime);//temp是较早时间
if ((temp.hour == time_out.hour) && (temp.min == time_out.min) && (temp.sec == time_out.sec))
{
continue;
}
else
{
ltime = time_out;
lpersonID = ID;
}
}

}

cout << fpersonID<<" "<<lpersonID;

return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: