您的位置:首页 > 其它

POJ 2482 扫描线(面积覆盖最大次数)

2015-07-07 20:06 330 查看
Stars in Your Window

Time Limit: 1000MSMemory Limit: 65536K
Total Submissions: 10806Accepted: 2980
Description

Fleeting time does not blur my memory of you. Can it really be 4 years since I first saw you? I still remember, vividly, on the beautiful Zhuhai Campus, 4 years ago, from the moment I saw you smile, as you were walking out of the classroom and turned your head back, with the soft sunset glow shining on your rosy cheek, I knew, I knew that I was already drunk on you. Then, after several months’ observation and prying, your grace and your wisdom, your attitude to life and your aspiration for future were all strongly impressed on my memory. You were the glamorous and sunny girl whom I always dream of to share the rest of my life with. Alas, actually you were far beyond my wildest dreams and I had no idea about how to bridge that gulf between you and me. So I schemed nothing but to wait, to wait for an appropriate opportunity. Till now — the arrival of graduation, I realize I am such an idiot that one should create the opportunity and seize it instead of just waiting.

These days, having parted with friends, roommates and classmates one after another, I still cannot believe the fact that after waving hands, these familiar faces will soon vanish from our life and become no more than a memory. I will move out from school tomorrow. And you are planning to fly far far away, to pursue your future and fulfill your dreams. Perhaps we will not meet each other any more if without fate and luck. So tonight, I was wandering around your dormitory building hoping to meet you there by chance. But contradictorily, your appearance must quicken my heartbeat and my clumsy tongue might be not able to belch out a word. I cannot remember how many times I have passed your dormitory building both in Zhuhai and Guangzhou, and each time aspired to see you appear in the balcony or your silhouette that cast on the window. I cannot remember how many times this idea comes to my mind: call her out to have dinner or at least a conversation. But each time, thinking of your excellence and my commonness, the predominance of timidity over courage drove me leave silently.

Graduation, means the end of life in university, the end of these glorious, romantic years. Your lovely smile which is my original incentive to work hard and this unrequited love will be both sealed as a memory in the deep of my heart and my mind. Graduation, also means a start of new life, a footprint on the way to bright prospect. I truly hope you will be happy everyday abroad and everything goes well. Meanwhile, I will try to get out from puerility and become more sophisticated. To pursue my own love and happiness here in reality will be my ideal I never desert.

Farewell, my princess!

If someday, somewhere, we have a chance to gather, even as gray-haired man and woman, at that time, I hope we can be good friends to share this memory proudly to relight the youthful and joyful emotions. If this chance never comes, I wish I were the stars in the sky and twinkling in your window, to bless you far away, as friends, to accompany you every night, sharing the sweet dreams or going through the nightmares together.



Here comes the problem: Assume the sky is a flat plane. All the stars lie on it with a location (x, y). for each star, there is a grade ranging from 1 to 100, representing its brightness, where 100 is the brightest and 1 is the weakest. The window is a rectangle whose edges are parallel to the x-axis or y-axis. Your task is to tell where I should put the window in order to maximize the sum of the brightness of the stars within the window. Note, the stars which are right on the edge of the window does not count. The window can be translated but rotation is not allowed.
Input

There are several test cases in the input. The first line of each case contains 3 integers: n, W, H, indicating the number of stars, the horizontal length and the vertical height of the rectangle-shaped window. Then n lines follow, with 3 integers each: x, y, c, telling the location (x, y) and the brightness of each star. No two stars are on the same point.

There are at least 1 and at most 10000 stars in the sky. 1<=W,H<=1000000, 0<=x,y<2^31.
Output

For each test case, output the maximum brightness in a single line.
Sample Input

3 5 4
1 2 3
2 3 2
6 3 1
3 5 4
1 2 3
2 3 2
5 3 1

Sample Output

5
6

Source

POJ Contest,Author:kinfkong@ZSU

题目意思:
给n个点的坐标和该点的价值,然后给一个n*m的矩形框,求矩形框住点的最大的总价值。

思路:
好像2014上海邀请赛出过类似的题目,那个是框住点最多的数目。把这道题价值转换为点的数目即在坐标(x,y)处有val个单位价值点(val为原题中点的价值),那么题目就转换成2014上海邀请赛的那道题了。
那么怎么求矩形框住点最大的数目呢?
以每个点为左下角创建一个矩形(和给出的矩形框形状大小一致),那么重叠的面积最多的次数即为答案(证明很简单)。
怎么求重叠面积次数呢?
扫描线变形 = = 每个矩形下边的值为val,上边的值为-val,扫描线扫一遍即得出答案。

代码:

#include <cstdio>
#include <cstring>
#include <algorithm>
#include <iostream>
#include <vector>
#include <queue>
#include <cmath>
#include <set>
using namespace std;

#define N 10005
#define ll root<<1
#define rr root<<1|1
#define mid (a[root].l+a[root].r)/2

__int64 max(__int64 x,__int64 y){return x>y?x:y;}
__int64 min(__int64 x,__int64 y){return x<y?x:y;}
__int64 abs(__int64 x,__int64 y){return x<0?-x:x;}

struct node{
__int64 l, r, val, maxh;
}a[N*8];

struct Line{
__int64 x1, x2, y, val;
Line(){}
Line(__int64 a,__int64 b,__int64 c,__int64 d){
x1=a;
x2=b;
y=c;
val=d;
}
}line[N*2];

bool cmp(Line a,Line b){
if(a.y==b.y) return a.val>b.val;
return a.y<b.y;
}

struct Po__int64{
__int64 x, y, val;
}p
;

__int64 n, w, h;
__int64 nx;
__int64 xx[N*2];

__int64 b_s(__int64 key){
__int64 l=0, r=nx-1;
while(l<=r){
__int64 mm=(l+r)/2;
if(xx[mm]==key) return mm;
else if(xx[mm]>key) r=mm-1;
else if(xx[mm]<key) l=mm+1;
}
}

void build(__int64 l,__int64 r,__int64 root){
a[root].l=l;
a[root].r=r;
a[root].val=a[root].maxh=0;
if(l==r) return;
build(l,mid,ll);
build(mid+1,r,rr);
}

void up(__int64 root){
if(a[root].l==a[root].r) a[root].maxh=a[root].val;
else a[root].maxh=a[root].val+max(a[ll].maxh,a[rr].maxh);
}

void update(__int64 l,__int64 r,__int64 val,__int64 root){
if(l>r) return;
if(a[root].l==l&&a[root].r==r){
a[root].val+=val;
up(root);
return;
}
if(r<=a[ll].r) update(l,r,val,ll);
else if(l>=a[rr].l) update(l,r,val,rr);
else{
update(l,mid,val,ll);
update(mid+1,r,val,rr);
}
up(root);
}

int main()
{
__int64 i, j, k;
while(scanf("%I64d %I64d %I64d",&n,&w,&h)==3){
nx=k=0;
for(i=0;i<n;i++){
scanf("%I64d %I64d %I64d",&p[i].x,&p[i].y,&p[i].val);
line[k++]=Line(p[i].x,p[i].x+w-1,p[i].y,p[i].val);
line[k++]=Line(p[i].x,p[i].x+w-1,p[i].y+h-1,-p[i].val);
xx[nx++]=p[i].x;
xx[nx++]=p[i].x+w-1;
}
sort(xx,xx+nx);
nx=unique(xx,xx+nx)-xx;
build(0,nx,1);
__int64 ans=0;
sort(line,line+k,cmp);
for(i=0;i<k-1;i++){
update(b_s(line[i].x1),b_s(line[i].x2),line[i].val,1);
ans=max(ans,a[1].maxh);
}
printf("%I64d\n",ans);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: