您的位置:首页 > 编程语言 > C语言/C++

1001. A+B Format (20)

2015-07-06 13:35 633 查看


1001. A+B Format (20)

时间限制

400 ms

内存限制

65536 kB

代码长度限制

16000 B

判题程序

Standard

作者

CHEN, Yue

Calculate a + b and output the sum in standard format -- that is, the digits must be separated into groups of three by commas (unless there are less than four digits).

Input

Each input file contains one test case. Each case contains a pair of integers a and b where -1000000 <= a, b <= 1000000. The numbers are separated by a space.

Output

For each test case, you should output the sum of a and b in one line. The sum must be written in the standard format.
Sample Input
-1000000 9

Sample Output

-999,991

题目很简单,求两个数的和,然后标准化格式输出。我用的是将求和之后的数,转化成字符串来处理的

#include<vector>
#include <sstream>
#include<cmath>
#include<iomanip>
#include<iostream>
#include <ctype.h>
#include <stdlib.h>
#include <algorithm>

using namespace std;

//1001. A + B Format(20)http://www.patest.cn/contests/pat-a-practise/1001
int main()
{
int a, b;
cin >> a >> b;
long int sum = a + b;//输入两个数,直接计算和
//下面是要处理格式化输出的问题
vector<char> s;
if (abs(sum) > 999)//如果数大于等于1000,才需要做处理
{
string str;
stringstream ss;
ss << sum;
str = ss.str();//我是将这个数转化为字符串进行处理的
int count = 0;
for (int i = str.length() - 1; i >= 0; i--)
{
count++;
s.push_back(str[i]);
if (count % 3 == 0)//每隔三位数,添加一次逗号,标准化后的字符串存入容器s中
{
s.push_back(',');
}
}

if (s[s.size() - 1] == ',')//判断最后一位是否为逗号,因为可能出现数据的位数正好是三倍数的情况,如3位,6位,9位等
{
//处理正数的情况
for (int j = s.size() - 2; j >= 0; j--)
{
cout << s[j];
}
}
else if ((s[s.size() - 1] == '-') && (s[s.size() - 2] == ','))//处理负数的情况
{
cout << s[s.size() - 1];
for (int j = s.size() - 3; j >= 0; j--)
{
cout << s[j];
}
}
else//处理位数不是三倍数的情况,即直接输出即可
{
for (int j = s.size() - 1; j >= 0; j--)
{
cout << s[j];
}
}
}
else//概述小于1000.直接输出即可
{
cout << sum;
}

return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签:  C++