您的位置:首页 > 其它

ZOJ 3430 Detect the Virus

2015-07-04 15:20 351 查看
传送门: 3430 Detect the Virus                                                                                                                                                                                                                                                                           
Detect the Virus
Time Limit: 2 Seconds      Memory Limit: 65536 KB

One day, Nobita found that his computer is extremely slow. After several hours' work, he finally found that it was a virus that made his poor computer slow and the virus was activated by a misoperation of opening an attachment of an email.

Nobita did use an outstanding anti-virus software, however, for some strange reason, this software did not check email attachments. Now Nobita decide to detect viruses in emails by himself.

To detect an virus, a virus sample (several binary bytes) is needed. If these binary bytes can be found in the email attachment (binary data), then the attachment contains the virus.

Note that attachments (binary data) in emails are usually encoded in base64. To encode a binary stream in base64, first write the binary stream into bits. Then take 6 bits from the stream in turn, encode these 6 bits into a base64 character according the following table:

That is, translate every 3 bytes into 4 base64 characters. If the original binary stream contains 3k + 1 bytes, where k is an integer, fill last bits using zero when encoding and append '==' as padding. If the original binary stream contains 3k + 2 bytes, fill last bits using zero when encoding and append '=' as padding. No padding is needed when the original binary stream contains 3k bytes.

 

Value 0 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31
Encoding A B C D E F G H I J K L M N O P Q R S T U V W X Y Z a b c d e f
Value 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49 50 51 52 53 54 55 56 57 58 59 60 61 62 63
Encoding g h i j k l m n o p q r s t u v w x y z 0 1 2 3 4 5 6 7 8 9 + /

For example, to encode 'hello' into base64, first write 'hello' as binary bits, that is: 01101000 01100101 01101100 01101100 01101111
Then, take 6 bits in turn and fill last bits as zero as padding (zero padding bits are marked in bold): 011010 000110 010101 101100 011011 000110 111100
They are 26 6 21 44 27 6 60 in decimal. Look up the table above and use corresponding characters: aGVsbG8
Since original binary data contains 1 * 3 + 2 bytes, padding is needed, append '=' and 'hello' is finally encoded in base64: aGVsbG8=

Section 5.2 of RFC 1521 describes how to encode a binary stream in base64 much more detailedly:

Click here to see Section 5.2 of RFC 1521 if you have interest

Here is a piece of ANSI C code that can encode binary data in base64. It contains a function, encode (infile, outfile), to encode binary file infile in base64 and output result to outfile.

Click here to see the reference C code if you have interest

Input

Input contains multiple cases (about 15, of which most are small ones). The first line of each case contains an integer N (0 <= N <= 512). In the next N distinct lines, each line contains a sample of a kind of virus, which is not empty, has not more than 64 bytes in binary and is encoded in base64. Then, the next line contains an integer M (1 <= M <= 128). In the following M lines, each line contains the content of a file to be detected, which is not empty, has no more than 2048 bytes in binary and is encoded in base64.

There is a blank line after each case.

Output

For each case, output M lines. The ith line contains the number of kinds of virus detected in the ith file.

Output a blank line after each case.

Sample Input

3
YmFzZTY0
dmlydXM=
dDog
1
dGVzdDogdmlydXMu

1
QA==
2
QA==
ICAgICAgICA=

Sample Output

2

1
0

Hint

In the first sample case, there are three virus samples: base64, virus and t: , the data to be checked is test: virus., which contains the second and the third, two virus samples.

Author: WU, Jun
Contest: ZOJ Monthly, November 2010

-----------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------

Solution: A-C Automation

注意:

1.弄清题意,“If these binary bytes can be found in the email attachment (binary data), then the attachment contains the virus.“题意是,将base64编码的模式串与文本串翻译成ASCII编码的字符串,再进行匹配。并不是将两者翻译成二进制(0-1串)进行匹配

2.也可将模式串与文本串翻译成0-1串做匹配,但注意匹配的位置必须是整字节处。这样做代码更简洁,内存与时间都更优(Maybe, 因为字符集是{0, 1})。

 

#include<bits/stdc++.h>
using namespace std;
const char *m1="ABCDEFGHIJKLMNOPQRSTUVWXYZabcdefghijklmnopqrstuvwxyz0123456789+/";
int m2[256];
void build_map(){
for(int i=0; m1[i]; i++){
m2[m1[i]]=i;
}
}
const int MAX_N=1e6+10, ls=500, lt=2e4, MAX_M=520;
bool s[ls], t[lt], used[MAX_M];
char v[ls], f[lt];
int q[MAX_N], head, tail;
struct node
{
int pre, id, pos[2], last;
void init(){
id=0;
memset(pos, 0, sizeof(pos));
}
};
node trie[MAX_N];
void b2b(char ch, bool *b, int &i){
if(ch=='=') i-=2;
else{
int p=32;
while(p){
b[i++]=m2[ch]&p;
p>>=1;
}
}
}
int trans(char *s, bool *b){
int i=0, j=0;
for(; s[i]; i++){
b2b(s[i], b, j);
}
//for(int i=0; i<j; i++) printf("%d", b[i]);
//puts("");
return j;
}
int build_trie(int N){
int tot=0, now, len;
trie[tot].init();
for(int id=1; id<=N; id++){
scanf("%s", v);
len=trans(v, s);
now=0;
for(int i=0; i<len; i++){
int &nt=trie[now].pos[s[i]];  //error-prone
now=nt?nt:(trie[++tot].init(), nt=tot);
}
trie[now].id=id;
}
return tot;
}
void build_ac(){
head=tail=0;
trie[0].last=0;
for(int i=0; i<2; i++){
int &nt=trie[0].pos[i];
if(nt){
trie[nt].pre=0;
trie[nt].last=0;
q[tail++]=nt;
}
}
int pre;
while(head!=tail){
int &top=q[head++];
for(int i=0; i<2; i++){
int &nt=trie[top].pos[i];
pre=trie[top].pre;
if(!nt) nt=trie[pre].pos[i];
else{
q[tail++]=nt;
while(!trie[pre].pos[i]&&pre) pre=trie[pre].pre;
pre=trie[nt].pre=trie[pre].pos[i];
int &last=trie[nt].last;
last=trie[pre].id?pre:trie[pre].last; //error-prone
}
}
}
}
void get_ans(int pre, int &cnt){  //error-prone
pre=trie[pre].id?pre:trie[pre].last;
while(pre && !used[trie[pre].id]){
used[trie[pre].id]=true;
cnt++;
pre=trie[pre].last;
}
}
void match(int N){
while(N--){
scanf("%s", f);
int len=trans(f, t);
memset(used, 0, sizeof(used));
int cnt=0;
for(int i=0, pre=0; i<len; i++){
pre=trie[pre].pos[t[i]];
if(i%8==7){
get_ans(pre, cnt);
}
}
printf("%d\n", cnt);
}
}

int main(){
//freopen("in", "r", stdin);
build_map();
int N, M;
while(~scanf("%d", &N)){
build_trie(N);
build_ac();
scanf("%d", &M);
match(M);
puts("");
}
return 0;
}

 

内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: