您的位置:首页 > 其它

POJ-1703-Find them, Catch them

2015-07-03 15:46 225 查看
DescriptionThe police office in Tadu City decides to say ends to the chaos, as launch actions to root up the TWO gangs in the city, Gang Dragon and Gang Snake. However, the police first needs to identify which gang a criminal belongs to. The present question is, given two criminals; do they belong to a same clan? You must give your judgment based on incomplete information. (Since the gangsters are always acting secretly.)Assume N (N <= 10^5) criminals are currently in Tadu
City, numbered from 1 to N. And of course, at least one of them belongs
to Gang Dragon, and the same for Gang Snake. You will be given M (M
<= 10^5) messages in sequence, which are in the following two kinds:1. D [a] [b]where [a] and [b] are the numbers of two criminals, and they belong to different gangs.2. A [a] [b]where [a] and [b] are the numbers of two criminals. This requires you to decide whether a and b belong to a same gang.InputThe first line of the input contains a single integer T (1 <= T
<= 20), the number of test cases. Then T cases follow. Each test case
begins with a line with two integers N and M, followed by M lines each
containing one message as described above.OutputFor each message "A [a] [b]" in each case, your program should give the
judgment based on the information got before. The answers might be one
of "In the same gang.", "In different gangs." and "Not sure yet."Sample Input
1
5 5
A 1 2
D 1 2
A 1 2
D 2 4
A 1 4
Sample Output
Not sure yet.
In different gangs.
In the same gang.
#include<cstdio>
#include<cstring>
int rank[1000000],pa[1000000];
int cha(int k)
{
if(pa[k]!=k)
{
int t=pa[k];
pa[k]=cha(pa[k]);
rank[k]=(rank[k]+rank[t])%2;//不断更新
}
return pa[k];
}
bool bing(int x,int y)
{
int x2=cha(x);
int y2=cha(y);
if(x2!=y2)
{
pa[y2]=x2;//设为同一根节点后(不用根节点区分),方便用rank的值来区分
rank[y2]=(rank[x]-rank[y]+1)%2;//用于标记它俩是否是属于同一帮派
}
return true;
}
void init(int n)
{
for(int i=1; i<=n; i++)
{
pa[i]=i;
rank[i]=0;
}
}
int main()
{
int cas,i,j,m,n,p1,p2,x2,y2;
char k[2];
scanf("%d",&cas);
while(cas--)
{

scanf("%d%d",&n,&m);//n代表人数,m代表测试数据
init(n);
for(i=1; i<=m; i++)
{
scanf("%s%d%d",k,&p1,&p2);
if(k[0]=='A')
{
x2=cha(p1);
y2=cha(p2);
if(x2!=y2)
printf("Not sure yet.\n");//是第一次出现,根节点不相同时,还不能确定是否为同一帮派
else
{
if(rank[p2]==rank[p1])
printf("In the same gang.\n");
else
printf("In different gangs.\n");
}
}
if(k[0]=='D')
{
bing(p1,p2);
}
}

}
return 0;
}
2015-07-03,15:45:47

                                            
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: