您的位置:首页 > 产品设计 > UI/UE

杭电1005 Number Sequence

2015-06-28 14:43 495 查看
Problem Description
A number sequence is defined as follows:

f(1) = 1, f(2) = 1, f(n) = (A * f(n - 1) + B * f(n - 2)) mod 7.

Given A, B, and n, you are to calculate the value of f(n).



Input
The input consists of multiple test cases. Each test case contains 3 integers A, B and n on a single line (1 <= A, B <= 1000, 1 <= n <= 100,000,000). Three zeros signal the end of input and this test case is not to be processed.



Output
For each test case, print the value of f(n) on a single line.



Sample Input
1 1 3
1 2 10
0 0 0




Sample Output
2
5




#include<stdio.h>

int f[100000005];
int main()
{
    int a,b,n,i,j;

    f[1]=1;f[2]=1;
    while(scanf("%d%d%d",&a,&b,&n),a+b+n)
    {
        int s=0;//记录周期       
        for(i=3;i<=n;i++)
        {
            f[i]=(a*f[i-1]+b*f[i-2])%7;
            for(j=2;j<i;j++)
            if(f[i-1]==f[j-1]&&f[i]==f[j])
            {
                s=i-j;
                
                break;
            }
            if(s>0) break;
        }
        if(s>0)
        {
            f
=f[(n-j)%s+j];                
        }
        printf("%d\n",f
);

    }
    return 0;
}



内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: