您的位置:首页 > 其它

第十二届浙江省大学生程序设计大赛-Capture the Flag

2015-06-26 14:35 309 查看
Capture the Flag

Time Limit: 2 Seconds Memory Limit: 65536 KB Special Judge

In computer security, Capture the Flag (CTF) is a computer security competition. CTF contests are usually designed to serve as an educational exercise to give participants experience in securing a machine, as well as conducting and reacting to the sort of attacks found in the real world. Reverse-engineering, network sniffing, protocol analysis, system administration, programming, and cryptanalysis are all skills which have been required by prior CTF contests at DEF CON. There are two main styles of capture the flag competitions: attack/defense and jeopardy.

In an attack/defense style competition, each team is given a machine (or a small network) to defend on an isolated network. Teams are scored on both their success in defending their assigned machine and on their success in attacking other team’s machines. Depending on the nature of the particular CTF game, teams may either be attempting to take an opponent’s flag from their machine or teams may be attempting to plant their own flag on their opponent’s machine.

Recently, an attack/defense style competition called MCTF held by Marjar University is coming, and there are N teams which participate in the competition. In the beginning, each team has S points as initial score; during the competition, there are some checkpoints which will renew scores for all teams. The rules of the competition are as follows:

If a team has been attacked for a service P, they will lose N - 1 points. The lost points will be split equally and be added to the team(s) which attacks successfully. For example, there are 4 teams and Team A has been attacked by Team B and Team C, so Team A will lose 3 points, while Team B and Team C each will get 1.5 points.
If a team cannot maintain their service well, they will lose N - 1 points, which will be split equally too and be added to the team(s) which maintains the service well.


The score will be calculated at the checkpoints and then all attacks will be re-calculated. Edward is the organizer of the competition and he needs to write a program to display the scoreboard so the teams can see their scores instantly. But he doesn’t know how to write. Please help him!

Input

There are multiple test cases. The first line of input contains an integer T indicating the number of test cases. For each test case:

The first line contains four integers N (2 <= N <= 100) - the number of teams, Q - the number of services (1 <= Q <= 10), S - the initial points (0 <= S <= 100000) and C - the number of checkpoints (1 <= C <= 100).

For each checkpoint, there are several parts:

The first line contains an integer A - the number of the successful attacks. Then A lines follow and each line contains a message:

[The No. of the attacker] [The No. of the defender] [The No. of the service]

For example, "1 2 3" means the 1st team attacks the 2nd team in service 3 successfully. The No. of teams and services are indexed from 1. You should notice that duplicate messages are invalid because of the rules. Just ignore them.
Then there are Q lines and each line contains N integers. The jth number of the ith line indicating the jth team's maintaining status of the ith service, where 1 means well and 0 means not well.
Finally there is an integer U (0 <= U <= 100), which describing the number of the queries. The following line contains U integers, which means Edward wants to know the score and the ranking of these teams.


Output

For each query L, output the score and the ranking of the Lth team. The relative error or absolute error of the score should be less than 10-5. The team with higher score gets higher rank; the teams with the same scores should have the same rank. It is guaranteed that the scores of any two teams are either the same or with a difference greater than 10-5.

Sample Input

1

4 2 2500 5

0

1 1 1 1

1 1 1 1

4

1 2 3 4

2

1 2 1

3 2 1

1 1 1 1

1 1 1 1

4

1 2 3 4

1

1 2 2

1 1 1 1

1 1 1 0

4

1 2 3 4

0

0 0 0 0

0 0 0 0

4

1 2 3 4

0

1 1 1 1

1 1 1 1

2

1 4

Sample Output

2500.00000000 1

2500.00000000 1

2500.00000000 1

2500.00000000 1

2501.50000000 1

2497.00000000 4

2501.50000000 1

2500.00000000 3

2505.50000000 1

2495.00000000 4

2502.50000000 2

2497.00000000 3

2499.50000000 1

2489.00000000 4

2496.50000000 2

2491.00000000 3

2499.50000000 1

2491.00000000 3

#include <iostream>

#include <string>

#include <stdio.h>

#include<algorithm>

#include<string.h>

#include<cmath>

#include<stack>

#include<queue>

#define exp 1e-5

using namespace std;// 大水题;

const int MAX=10000+10;

struct node
{
int ID;

int rank;

double sore;
}inf[110];

bool vis[110][110][15];

bool has[110];

bool cmp1(node a,node b)
{
return a.sore>b.sore;
}

bool cmp2(node a,node b)
{
return a.ID<b.ID;
}

int main()
{

int T,N,Q,C,k;

double P;

scanf("%d",&T);

while(T--)
{

scanf("%d %d %lf %d",&N,&Q,&P,&C);

for(int i=0;i<=N;i++)
{
inf[i].ID=i;
inf[i].rank=1;
inf[i].sore=P;
}

while(C--)
{
scanf("%d",&k);

memset(vis,false,sizeof(vis));

for(int i=0;i<k;i++)
{
int a,d,s;

scanf("%d %d %d",&a,&d,&s);

if(!vis[a][d][s])
{
vis[a][d][s]=true;
}

}
for(int i=1;i<=Q;i++)
{

for(int j=1;j<=N;j++)
{
int ans=0;

for(int kk=1;kk<=N;kk++)
{
if(vis[kk][j][i])
{
ans++;
}
}
if(!ans)
{
continue;
}
double sa=1.0*(N-1)/ans;

inf[j].sore-=(N-1);

for(int kk=1;kk<=N;kk++)
{
if(vis[kk][j][i])
{
inf[kk].sore+=sa;
}
}
}
}
for(int i=1;i<=Q;i++)
{
int ans=0;

memset(has,false,sizeof(has));
for(int j=1;j<=N;j++)
{
int sa;
scanf("%d",&sa);
if(sa)
{
has[j]=true;
ans++;
}
else
{
inf[j].sore-=(N-1);
}
}
if(ans==N)
{
continue;
}
double ss=1.0*(N-1)/ans;
ss=(N-ans)*ss;
for(int j=1;j<=N;j++)
{
if(has[j])
{
inf[j].sore+=ss;
}
}
}
sort(inf+1,inf+N+1,cmp1);

for(int i=1;i<=N;i++)
{
if(i!=1)
{
if(fabs(inf[i].sore-inf[i-1].sore)<exp)
{
inf[i].rank=inf[i-1].rank;
}
else
{
inf[i].rank=i;
}
}
else
{
inf[i].rank=i;
}
}

sort(inf+1,inf+N+1,cmp2);//前一次排序的ID已乱,重排;

scanf("%d",&k);

while(k--)
{
int sa;

scanf("%d",&sa);

printf("%f %d\n",inf[sa].sore,inf[sa].rank);

}
}
}
return 0;

}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: