您的位置:首页 > 其它

Poj3295  Tautology

2015-06-26 11:06 204 查看
Tautology

Time Limit: 1000MSMemory Limit: 65536K
Total Submissions: 10425Accepted: 3956
Description

WFF 'N PROOF is a logic game played with dice. Each die has six faces representing some subset of the possible symbols K, A, N, C, E, p, q, r, s, t. A Well-formed formula (WFF) is any string of these symbols obeying the following rules:

p, q, r, s, and t are WFFs
if w is a WFF, Nw is a WFF
if w and x are WFFs, Kwx, Awx, Cwx, and Ewx are WFFs.

The meaning of a WFF is defined as follows:

p, q, r, s, and t are logical variables that may take on the value 0 (false) or 1 (true).
K, A, N, C, E mean and, or, not, implies, and equals as defined in the truth table below.

Definitions of K, A, N, C, and E
w x Kwx Awx Nw Cwx Ewx
1 1 1 1 0 1 1
1 0 0 1 0 0 0
0 1 0 1 1 1 0
0 0 0 0 1 1 1
A tautology is a WFF that has value 1 (true) regardless of the values of its variables. For example, ApNp is a tautology because it is true regardless of the value of p. On the other hand, ApNq is not, because it has the
value 0 for p=0, q=1.

You must determine whether or not a WFF is a tautology.

Input

Input consists of several test cases. Each test case is a single line containing a WFF with no more than 100 symbols. A line containing 0 follows the last case.

Output

For each test case, output a line containing tautology or not as appropriate.

Sample Input
ApNp
ApNq
0

Sample Output
tautology
not

此题虽然做法是用构造法但是,还是用栈求表达式的方法。题目大意就是求出表达式若最后的表达式值为1输出
tautology,else有一个为假输出not,即看是否为永真式。


#include <iostream>
#include<cstdio>
#include<cstring>
char st[1000];
int q,p,s,r,t,c[1000];
using namespace std;
void D()
{
    int z=0,x,y;
    int l=strlen(st);
    for(int i=l-1;i>=0;i--)//要倒着进行操作因为栈的处理最后进入的线处理
    {
        if(st[i]=='p')//p,q,r,s,t的取值只有0,1
            c[z++]=p;
        else if(st[i]=='q')
            c[z++]=q;
        else if(st[i]=='r')
            c[z++]=r;
        else if(st[i]=='s')
            c[z++]=s;
        else if(st[i]=='t')
            c[z++]=t;
        else if(st[i]=='K')
            {
                x=c[--z];
                y=c[--z];
                c[z++]=(x&&y);
            }
        else if(st[i]=='A')
            {
                x=c[--z];
                y=c[--z];
                c[z++]=(x||y);
            }
        else if(st[i]=='N')
            {
                x=c[--z];
                c[z++]=(!x);
            }
        else if(st[i]=='C')
            {
                x=c[--z];
                y=c[--z];
                if(x==1&&y==0)
                    c[z++]=0;
                else
                    c[z++]=1;
            }
        else if(st[i]=='E')
            {
                x=c[--z];
                y=c[--z];
                if( (x==0&&y==0)||(x==1&&y==1) )
                    c[z++]=1;
                else
                    c[z++]=0;
            }
    }
}
int solve()
{
    for(p=0;p<2;p++)
        for(q=0;q<2;q++)
            for(r=0;r<2;r++)
                for(s=0;s<2;s++)
                    for(t=0;t<2;t++)
                    {
                            D();
                            if(c[0]==0)//有一个假就输出not
                                return 0;
                    }
     return 1;
}
int main()
{
    int n,m,i,j,k;
    while(cin>>st)
    {
        if(!strcmp(st,"0"))
            break;
        if(solve())//注意并不是输入什么字符才进行对这些字符的处理,而是整体都考虑
            cout<<"tautology"<<endl;
        else
            cout<<"not"<<endl;
    }
    return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: