您的位置:首页 > 其它

Encoding

2015-06-25 21:56 183 查看
Encoding

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)

Total Submission(s): 32145 Accepted Submission(s): 14263

Problem Description

Given a string containing only ‘A’ - ‘Z’, we could encode it using the following method:

Each sub-string containing k same characters should be encoded to “kX” where “X” is the only character in this sub-string.

If the length of the sub-string is 1, ‘1’ should be ignored.

Input

The first line contains an integer N (1 <= N <= 100) which indicates the number of test cases. The next N lines contain N strings. Each string consists of only ‘A’ - ‘Z’ and the length is less than 10000.

Output

For each test case, output the encoded string in a line.

Sample Input

2

ABC

ABBCCC

Sample Output

ABC

A2B3C

看错了题,错了好几次

#include <iostream>
#include <cstring>
#include <cstdio>
#include <cmath>

using namespace std;

struct AZ
{
char s[11100];
int num;
int len;
void Input()
{
scanf("%s",s);
}
void CAL()
{
len=strlen(s);
for(int i=0; i<len; i++)
{
num=1;
while(s[i]==s[i+1])
{
i++;
num++;
}
if(num!=1)
{
cout<<num<<s[i];
}
else
{
cout<<s[i];
}
}
cout<<endl;
}

} a;
int main()
{
int n;
scanf("%d",&n);
while(n--)
{
a.Input();
a.CAL();
}

return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: