您的位置:首页 > 其它

hdu 3549

2015-06-25 10:16 330 查看


Flow Problem

Time Limit: 5000/5000 MS (Java/Others) Memory Limit: 65535/32768 K (Java/Others)

Total Submission(s): 9868 Accepted Submission(s): 4630



Problem Description

Network flow is a well-known difficult problem for ACMers. Given a graph, your task is to find out the maximum flow for the weighted directed graph.



Input

The first line of input contains an integer T, denoting the number of test cases.

For each test case, the first line contains two integers N and M, denoting the number of vertexes and edges in the graph. (2 <= N <= 15, 0 <= M <= 1000)

Next M lines, each line contains three integers X, Y and C, there is an edge from X to Y and the capacity of it is C. (1 <= X, Y <= N, 1 <= C <= 1000)



Output

For each test cases, you should output the maximum flow from source 1 to sink N.



Sample Input

2
3 2
1 2 1
2 3 1
3 3
1 2 1
2 3 1
1 3 1




Sample Output

Case 1: 1
Case 2: 2


最大流模板

#include<iostream>
#include<cstdio>
#include<cstring>
#include<cmath>
#include<queue>
using namespace std;
#define INF 0x3f3f3f3f
#define ll long long

int main()
{
    int n,m;
    int t,tt=1;
    int c[205][205],f[205];
    bool vis[205];
    int p[205];
    queue<int >q;
    scanf("%d",&t);
    while(t--&&scanf("%d%d",&n,&m))
    {
        memset(c,0,sizeof(c));  //c标记容量
        for(int i=0; i<m; i++)
        {
            int aa,bb,cc;
            scanf("%d%d%d",&aa,&bb,&cc);
            //if(aa!=bb)
                c[aa][bb]+=cc;  //可能会有重复边
        }
        int ff=0;
        while(1)
        {
            memset(vis,false ,sizeof(vis));  //记录当前点的流量
            memset(p,-1,sizeof(p));          //记录当前点的前驱
            for(int i=1;i<=n;i++)
                f[i]=INF;
            vis[1]=true ;
            while(q.size()) q.pop();
            q.push(1);
            while(q.size())
            {
                int st=q.front();
                q.pop();
                if(st==n) break;
                for(int i=1; i<=n; i++)
                {
                    if(!vis[i]&&c[st][i]>0)
                    {
                        vis[i]=true ;
                        f[i]=min(f[st],c[st][i]);                   //流量为当前路径的最大流量或者为当前点的最大流量
                        p[i]=st;                                    //记录前驱
                        q.push(i);
                    }
                }
            }

            if(!vis
) break;
            //cout<<f
<<endl;

            int st=n;
            while(st!=1)
            {
                int ed=p[st];
                c[ed][st]-=f
;
                c[st][ed]+=f
;
                st=ed;
            }

            ff+=f
;
        }

        printf("Case %d: %d\n",tt++,ff);
    }
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: