您的位置:首页 > 其它

【PAT】1032. 挖掘机技术哪家强(20)

2015-06-24 21:49 459 查看


1032. 挖掘机技术哪家强(20)

时间限制

200 ms

内存限制

65536 kB

代码长度限制

8000 B

判题程序

Standard

作者

CHEN, Yue

为了用事实说明挖掘机技术到底哪家强,PAT组织了一场挖掘机技能大赛。现请你根据比赛结果统计出技术最强的那个学校。

输入格式:

输入在第1行给出不超过105的正整数N,即参赛人数。随后N行,每行给出一位参赛者的信息和成绩,包括其所代表的学校的编号(从1开始连续编号)、及其比赛成绩(百分制),中间以空格分隔。

输出格式:

在一行中给出总得分最高的学校的编号、及其总分,中间以空格分隔。题目保证答案唯一,没有并列。
输入样例:
6
3 65
2 80
1 100
2 70
3 40
3 0

输出样例:
2 150


很简单的一道题,嘿嘿

#include "iostream"
#include "string"
#include "ctype.h"
#include "vector"
#include "algorithm"
#include "map"

using namespace std;

int main(){
//freopen("test.txt","r",stdin);
int N;
map<int,int> cc;
map<int,int>::iterator p;

scanf("%d\n",&N);
for (int i=0;i<N;i++)
{
int num;
int score;
scanf("%d %d",&num,&score);
cc[num]+=score;
}

int maxScore=0,maxId;
for (p=cc.begin();p!=cc.end();p++)
{
if (p->second>maxScore)
{
maxScore=p->second;
maxId=p->first;
}
}
cout<<maxId<<" "<<maxScore;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: