您的位置:首页 > 其它

Color the ball

2015-06-23 21:44 399 查看

Color the ball

Time Limit: 9000/3000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)

Total Submission(s): 11732 Accepted Submission(s): 5871



Problem Description
N个气球排成一排,从左到右依次编号为1,2,3....N.每次给定2个整数a b(a <= b),lele便为骑上他的“小飞鸽"牌电动车从气球a开始到气球b依次给每个气球涂一次颜色。但是N次以后lele已经忘记了第I个气球已经涂过几次颜色了,你能帮他算出每个气球被涂过几次颜色吗?


Input
每个测试实例第一行为一个整数N,(N <= 100000).接下来的N行,每行包括2个整数a b(1 <= a <= b <= N)。

当N = 0,输入结束。


Output
每个测试实例输出一行,包括N个整数,第I个数代表第I个气球总共被涂色的次数。


Sample Input
3
1 1
2 2
3 3
3
1 1
1 2
1 3
0




Sample Output
1 1 1
3 2 1




Author
8600


Source
HDU 2006-12 Programming Contest


先发一下超时的代码!

#include<cstdio>
#include<cstring>
#include<iostream>
using namespace std;
int a[100010];
int main()
{
    int n,b,c,i,m,f;
    while(cin>>n&&n)
    {
        m=n;
        f=0;
        memset(a,0,sizeof(a));
        while(n--)
        {
            cin>>b>>c;
            for(i=b;i<=c;i++)
            {
                a[i]++;
            }
        }
        for(i=1;i<m;i++)
        {
            cout<<a[i]<<" ";
        }
        cout<<a[i]<<endl;
    }
}

再发一下AC代码!写的真好!

#include<cstdio>
#include<cstring>
#include<iostream>
using namespace std;
int a[100010];
int main()
{
    int n,b,c,i,m,f;
    while(cin>>n&&n)
    {
        m=n;
        f=0;
        memset(a,0,sizeof(a));
        while(n--)
        {
            cin>>b>>c;
            a[b]++;//把这个点加一
            a[c+1]--;//这个点+1的那个点减一照成区间还原
        }
        for(i=1;i<m;i++)
        {
            f+=a[i];
            cout<<f<<" ";//不停相加!
        }
        cout<<a[i]+f<<endl;
    }
}


他解决这个题还是在点上赋值而不是区间赋值,利用一个变量不停的相加这个区间里的值而成,想法特别奇妙,赞一个!
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: