您的位置:首页 > 其它

C - Find The Multiple(BFS)

2015-06-21 15:18 337 查看
解题过程:直接暴搜;

解题思路:1,首先这个由01组成的数的开头一定是1。

2,每次在后面添上0或1 对所给的数取余,若为0则为这个数的解,不为0就继续在后面加0或加1。如此反复直到有解。

Tips:因为没做时间空间的优化,用C++编译器可能会TLE,用G++才能AC。

Description

Given a positive integer n, write a program to find out a nonzero multiple m of n whose decimal representation contains only the digits 0 and 1. You may assume that n is not greater than 200 and there is a corresponding m containing no more than 100 decimal
digits.

Input

The input file may contain multiple test cases. Each line contains a value of n (1 <= n <= 200). A line containing a zero terminates the input.

Output

For each value of n in the input print a line containing the corresponding value of m. The decimal representation of m must not contain more than 100 digits. If there are multiple solutions for a given value of n, any one of them is acceptable.

Sample Input

2
6
19
0


Sample Output

10
100100100100100100
111111111111111111


#include<cstdio>
#include<iostream>
#include<cmath>
#include<queue>

using namespace std;

void bfs(int x)
{
    queue<long long> que;
    que.push(1);
    while(que.size())
    {
        long long p = que.front();
        que.pop();
        if( p % x == 0)
        {
            printf("%lld\n", p);
            return;
        }
        que.push(p * 10);
        que.push(p * 10 + 1);
    }
}
int main()
{
    int x;
    while(scanf("%d", &x) && x)
    {
        bfs(x);
    }
    return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: