您的位置:首页 > 其它

poj 2001 字典树入门题(数组实现模板)

2015-06-14 14:52 375 查看
Shortest Prefixes

Time Limit: 1000MSMemory Limit: 30000K
Total Submissions: 14818Accepted: 6399
Description
A prefix of a string is a substring starting at the beginning of the given string. The prefixes of "carbon" are: "c", "ca", "car", "carb", "carbo", and "carbon". Note that the empty string is not considered a prefix in this problem,
but every non-empty string is considered to be a prefix of itself. In everyday language, we tend to abbreviate words by prefixes. For example, "carbohydrate" is commonly abbreviated by "carb". In this problem, given a set of words, you will find for each word
the shortest prefix that uniquely identifies the word it represents.

In the sample input below, "carbohydrate" can be abbreviated to "carboh", but it cannot be abbreviated to "carbo" (or anything shorter) because there are other words in the list that begin with "carbo".

An exact match will override a prefix match. For example, the prefix "car" matches the given word "car" exactly. Therefore, it is understood without ambiguity that "car" is an abbreviation for "car" , not for "carriage" or any of the other words in the list
that begins with "car".

Input
The input contains at least two, but no more than 1000 lines. Each line contains one word consisting of 1 to 20 lower case letters.

Output
The output contains the same number of lines as the input. Each line of the output contains the word from the corresponding line of the input, followed by one blank space, and the shortest prefix that uniquely (without ambiguity)
identifies this word.
Sample Input
carbohydrate
cart
carburetor
caramel
caribou
carbonic
cartilage
carbon
carriage
carton
car
carbonate

Sample Output
carbohydrate carboh
cart cart
carburetor carbu
caramel cara
caribou cari
carbonic carboni
cartilage carti
carbon carbon
carriage carr
carton carto
car car
carbonate carbona

Source
Rocky Mountain 2004
#include <iostream>
#include<stdio.h>
#include<string.h>
#include<algorithm>
using namespace std;
int ch[20*1000+200][27];
int sz;
int val[20*1000+200];
char s[1010][40];
void init()
{
sz=1;
memset(ch,0,sizeof(ch));
memset(val,0,sizeof(val));
}
void insert(char *s)
{
int u=0,c;
for(int i=0;i<strlen(s);i++)
{
c=s[i]-'a';
if(!ch[u][c])
ch[u][c]=sz++;
u=ch[u][c];
val[u]++;//此题val应该放在for里面
}
//val[u]=-1;
}
void search(char s[])
{
int u=0,c;
for(int i=0;i<strlen(s);i++)
{
c=s[i]-'a';
putchar(s[i]);
if(val[ch[u][c]]==1)
break;
u=ch[u][c];
}
putchar('\n');
}
int main()
{
// freopen("in.txt","r",stdin);
init();
int cnt=0;
while(~scanf("%s",s[cnt]))
{
insert(s[cnt]);
cnt++;
}
for(int i=0;i<cnt;i++)
{
printf("%s ",s[i]);
search(s[i]);
}

}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: