您的位置:首页 > 其它

[POJ_1068]Parencodings

2015-06-11 16:05 302 查看
Parencodings

Time Limit: 1000MSMemory Limit: 10000K
Total Submissions: 22719Accepted: 13313
Description

Let S = s1 s2...s2n be a well-formed string of parentheses. S can be encoded in two different ways:

q By an integer sequence P = p1 p2...pn where pi is the number of left parentheses before the ith right parenthesis in S (P-sequence).

q By an integer sequence W = w1 w2...wn where for each right parenthesis, say a in S, we associate an integer which is the number of right parentheses counting from the matched left parenthesis of a up to a. (W-sequence).

Following is an example of the above encodings:

S		(((()()())))

	P-sequence	    4 5 6666

	W-sequence	    1 1 1456


Write a program to convert P-sequence of a well-formed string to the W-sequence of the same string.

Input

The first line of the input contains a single integer t (1 <= t <= 10), the number of test cases, followed by the input data for each test case. The first line of each test case is an integer n (1 <= n <= 20), and the second line is the P-sequence of a well-formed
string. It contains n positive integers, separated with blanks, representing the P-sequence.
Output

The output file consists of exactly t lines corresponding to test cases. For each test case, the output line should contain n integers describing the W-sequence of the string corresponding to its given P-sequence.

Sample Input
2
6
4 5 6 6 6 6
9 
4 6 6 6 6 8 9 9 9

Sample Output
1 1 1 4 5 6
1 1 2 4 5 1 1 3 9


题意:

1. S 代表一个由左右括号严格组成的序列,可以分为 P 和 S 两种表达方法

2. P 序列代表:当前 匹配括号中的右括号 左边有多少个左括号;

3. W序列代表:当前 匹配的括号的右括号 中 包含多少个完整的括号;

要求根据 P序列求出W序列

由题意可知

1. P序列与W序列都是以 右括号为基准建立的

2. 括号严格对应,左右括号数量一致

3. 在条件1 和 2的基础上,可知我们可以一边模拟数组,同时进行括号的计数

建模

数组下标01234567891011
S(((()()())))
P456666
W111456
代码如下:

#include<stdio.h>

void main()
{
	int n,m,i,j,k,k0,match,len,cnt;
	char s[40];
	scanf("%d",&n);
	while(n--)
	{
		j = 0;    //j 代表当前填充的位置
		k0 = 0;
		scanf("%d",&m);     // m 右括号的个数
		for(i = 0; i < m; i++)
		{
			scanf("%d",&k);  //当前右括号左边左括号的个数
			for( ; k - k0 > 0; k0++ )  //k0为k前状态 k0, k ....
			{
				//模拟填充
				s[j++] = '(';
			}
			s[j++] = ')';      //j = k 填充 ‘)’为当前右括号
			len = j - 2;     //len 代表当前长度减去1,即当前位置前一位置
			for(cnt = 0,match = 1; (match != 0) && (len >= 0);len --)
			{
				if(s[len] == '(')
				{
					match --;  //match为0时 匹配成功
					cnt++;
				}else{
					match ++;  
				}
			}
			printf("%d",cnt);
			if(i != m-1) printf(" ");
			else printf("\n");
		}
	}
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: