您的位置:首页 > 其它

LA3644:X-Plosives(并查集)

2015-06-10 21:16 302 查看
A secret service developed a new kind of explosive that attain its volatile property only when a speci c

association of products occurs. Each product is a mix of two different simple compounds, to which we

call a binding pair. If N > 2, then mixing N different binding pairs containing N simple compounds

creates a powerful explosive. For example, the binding pairs A+B, B+C, A+C (three pairs, three

compounds) result in an explosive, while A+B, B+C, A+D (three pairs, four compounds) does not.

You are not a secret agent but only a guy in a delivery agency with one dangerous problem: receive

binding pairs in sequential order and place them in a cargo ship. However, you must avoid placing in

the same room an explosive association. So, after placing a set of pairs, if you receive one pair that

might produce an explosion with some of the pairs already in stock, you must refuse it, otherwise, you

must accept it.

An example. Lets assume you receive the following sequence: A+B, G+B, D+F, A+E, E+G,

F+H. You would accept the rst four pairs but then refuse E+G since it would be possible to make the

following explosive with the previous pairs: A+B, G+B, A+E, E+G (4 pairs with 4 simple compounds).

Finally, you would accept the last pair, F+H.

Compute the number of refusals given a sequence of binding pairs.

Input

The input will contain several test cases, each of them as described below. Consecutive

test cases are separated by a single blank line.

Instead of letters we will use integers to represent compounds. The input contains several lines.

Each line (except the last) consists of two integers (each integer lies between 0 and 105

) separated by

a single space, representing a binding pair.

Each test case ends in a line with the number `-1'. You may assume that no repeated binding pairs

appears in the input.

Output

For each test case, the output must follow the description below.

A single line with the number of refusals.

Sample Input

1 2

3 4

3 5

3 1

2 3

4 1

2 6

6 5

-1

Sample Output

3

题意:

每个化合物由两个数字组成,每个数字代表一个元素

要把这些化合物往箱子里装,但是要求装的化合的数量与元素的数量不能相等,那么有几个化合物无法装进箱子

思路:

首先看到这道题并没有思路,但是后来一画图,发现,其实确实是一个并查集

化合物的数量就是并查集上边的数量,元素的数量就是并查集上节点的数量

一旦形成环,那么正好就是节点数等于边的数量,不可行

#include <iostream>
#include <stdio.h>
#include <string.h>
#include <stack>
#include <queue>
#include <map>
#include <set>
#include <vector>
#include <math.h>
#include <bitset>
#include <algorithm>
#include <climits>
using namespace std;

#define LS 2*i
#define RS 2*i+1
#define UP(i,x,y) for(i=x;i<=y;i++)
#define DOWN(i,x,y) for(i=x;i>=y;i--)
#define MEM(a,x) memset(a,x,sizeof(a))
#define W(a) while(a)
#define gcd(a,b) __gcd(a,b)
#define LL long long
#define N 100005
#define MOD 1000000007
#define INF 0x3f3f3f3f
#define EXP 1e-8

int father
;

int find(int x)
{
    if(x == father[x])
    return father[x];
    return father[x] = find(father[x]);
}

int main()
{
    int x,y,i;
    while(~scanf("%d",&x))
    {
        for(i = 0;i<N;i++)
        father[i] = i;
        int ans = 0;
        while(x!=-1)
        {
            scanf("%d",&y);
            int rx = find(x),ry = find(y);
            if(rx!=ry)
            {
                father[ry] = rx;
            }
            else
            ans++;
            scanf("%d",&x);
        }
        printf("%d\n",ans);
    }

    return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: