您的位置:首页 > 产品设计 > UI/UE

Uva - 133 - The Dole Queue

2015-06-10 16:13 615 查看
In a serious attempt to downsize (reduce) the dole queue, The New National Green Labour Rhinoceros Party has decided on the following strategy. Every day all dole applicants will be placed in a large circle,
facing inwards. Someone is arbitrarily chosen as number 1, and the rest are numbered counter-clockwise up to N (who will be standing on 1's left). Starting from 1 and moving counter-clockwise, one labour official counts off k applicants, while another official
starts from N and moves clockwise, counting m applicants. The two who are chosen are then sent off for retraining; if both officials pick the same person she (he) is sent off to become a politician. Each official then starts counting again at the next available
person and the process continues until no-one is left. Note that the two victims (sorry, trainees) leave the ring simultaneously, so it is possible for one official to count a person already selected by the other official.

Input

Write a program that will successively read in (in that order) the three numbers (N, k and m; k, m > 0, 0 < N < 20) and determine the order in which the applicants are sent off for retraining. Each set of
three numbers will be on a separate line and the end of data will be signalled by three zeroes (0 0 0).

Output

For each triplet, output a single line of numbers specifying the order in which people are chosen. Each number should be in a field of 3 characters. For pairs of numbers list the person chosen by the counter-clockwise
official first. Separate successive pairs (or singletons) by commas (but there should not be a trailing comma).

Sample input

10 4 3
0 0 0


Sample output


4

8,

9

5,

3

1,

2

6,

10,

7

where

represents a space.

循环时候的增长步长方式注意

AC代码:

#include <iostream>
#include <cstdio>
#include <cstdlib>
#include <cctype>
#include <cstring>
#include <algorithm>

using namespace std;

int n, k, m;
int a[25];

int main()
{
while (scanf("%d%d%d", &n, &k, &m) && n) {
// 记得清空,虽然这道题目不清空没有什么影响
memset(a, 0, sizeof(a));
// 不清空不会影响结果,是因为这里将需要用到的都重新赋值了
for (int i = 1; i <= n; i++) {
a[i] = i;
}
// 剩下的人数
int leftPeople = n;
int pa = n, pb = 1;
while (leftPeople) {
// 用两个新的变量,不要改变k和m
int ka = k;
int mb = m;
while (ka--) {
pa = (pa + n) % n + 1;
while (a[pa] == 0) {
pa = (pa + n) % n + 1;
}
}
while (mb--) {
pb = (pb - 2 + n) % n + 1;
while (a[pb] == 0) {
pb = (pb - 2 + n) % n + 1;
}
}
printf("%3d", pa);
leftPeople--;
if (pa != pb) {
printf("%3d", pb);
leftPeople--;
}
a[pa] = a[pb] = 0;
if (leftPeople) {
printf(",");
}
}
printf("\n");
}

return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: