您的位置:首页 > 其它

杭电 1004

2015-06-10 00:25 344 查看

Let the Balloon Rise

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)

Total Submission(s): 87389 Accepted Submission(s): 33034



[align=left]Problem Description[/align]
Contest time again! How excited it is to see balloons floating around. But to tell you a secret, the judges' favorite time is guessing the most popular problem. When the contest is over, they will count the balloons of each color
and find the result.

This year, they decide to leave this lovely job to you.

[align=left]Input[/align]
Input contains multiple test cases. Each test case starts with a number N (0 < N <= 1000) -- the total number of balloons distributed. The next N lines contain one color each. The color of a balloon is a string of up to 15 lower-case
letters.

A test case with N = 0 terminates the input and this test case is not to be processed.

[align=left]Output[/align]
For each case, print the color of balloon for the most popular problem on a single line. It is guaranteed that there is a unique solution for each test case.

[align=left]Sample Input[/align]

5
green
red
blue
red
red
3
pink
orange
pink
0


[align=left]Sample Output[/align]

red
pink


分析:
字符串问题,统计所有字符串出现的次数,最后输出出现次数最大的字符串(可能不止一个,输出靠前的一个)
以下是用char* AC的代码
代码:
#include<iostream>
using namespace std;
int main()
{
int n;
while (scanf("%d",&n), n)
{
char a[1005] = { 0 };
char s[10005][16];
for (int i = 1;i <= n;i++)
{
scanf("%s", s[i]);
}
int max = 0;
for (int i = 1;i <= n;i++)
{
for (int j = i + 1;j <= n;j++)
{
if (strcmp(s[i], s[j]) == 0)
{
a[i] += 1;
}
}
if (a[i] > max)
{
max = a[i];
}
}
for (int l = 1;l <= n;l++)
{
if(a[l]==max)
printf("%s\n", s[l]);
}
}
return 0;
}

以下是用map容器 AC的代码

#include<string>
#include<map>
#include<iostream>
using namespace std;
int main()
{
int n;
while (cin >> n, n)
{
string color;
string max_color;
map<string, int> shuliang;
while (n--)
{
cin >> color;
if (shuliang.count(color) == 0)
shuliang[color] = 1;
else
shuliang[color] += 1;
if (shuliang[color] > shuliang[max_color])
max_color = color;
}
cout << max_color << endl;
}
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: