您的位置:首页 > 其它

HDOJ 3501 Calculation 2(欧拉函数拓展——求非互质数和)

2015-06-07 22:03 309 查看

Calculation 2

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)

Total Submission(s): 2548 Accepted Submission(s): 1064



Problem Description
Given a positive integer N, your task is to calculate the sum of the positive integers less than N which are not coprime to N. A is said to be coprime to B if A, B share no common positive divisors except
1.


Input
For each test case, there is a line containing a positive integer N(1 ≤ N ≤ 1000000000). A line containing a single 0 follows the last test case.


Output
For each test case, you should print the sum module 1000000007 in a line.


Sample Input
3
4
0




Sample Output
0
2




题意:求所有小于n的且与n为非互质数的和。

所有小于n且与n为非互质数和=所有小于n数的和-所有小于n且与n互质的数的和

求所有小于N且与N为互质数的和:

1.欧拉函数可求与N互质的数的个数

2.若已知m与n互质,则n-m也与n互质


具体代码如下:

#include<stdio.h>
#define mod 1000000007

__int64  eular(__int64 n)//欧拉函数模板 
{
	__int64 res=n,i;
	for(i=2;i*i<=n;i++)
	{
		if(n%i==0)
		   res=res/i*(i-1);//先进行除法是为了防止中间数据的溢出 
		while(n%i==0)
		   n/=i;
	}
	if(n>1)
	   res=res/n*(n-1);//保证x一定是素数 
	return res;
}

int main()
{
	__int64 n,ans;
	while(scanf("%I64d",&n)&&n)
	{
		ans=n*(n-1)/2;//求出所有小于n的正整数和 
		printf("%I64d\n",(ans-n*eular(n)/2)%mod);
	}// n*eular(n)/2为小于n且与n互质的数的和,因为若m与n互质,那么n-m也一定与n互质 
	return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: