您的位置:首页 > 其它

HDU 2669----Romantic(扩展欧几里德求乘法逆元)

2015-06-07 19:20 369 查看

我觉得这个算法的难点是对递归调用的理解

具体的参见我上一篇博客

[align=left]Problem Description[/align]
The Sky is Sprite.

The Birds is Fly in the Sky.

The Wind is Wonderful.

Blew Throw the Trees

Trees are Shaking, Leaves are Falling.

Lovers Walk passing, and so are You.

................................Write in English class by yifenfei



Girls are clever and bright. In HDU every girl like math. Every girl like to solve math problem!

Now tell you two nonnegative integer a and b. Find the nonnegative integer X and integer Y to satisfy X*a + Y*b = 1. If no such answer print "sorry" instead.

[align=left]Input[/align]
The input contains multiple test cases.

Each case two nonnegative integer a,b (0<a, b<=2^31)

[align=left]Output[/align]
output nonnegative integer X and integer Y, if there are more answers than the X smaller one will be choosed. If no answer put "sorry" instead.

[align=left]Sample Input[/align]

77 51
10 44
34 79


[align=left]Sample Output[/align]

2 -3
sorry
7 -3


#include<stdio.h>
int exgcd(__int64 a,__int64 b,__int64 &x,__int64 &y)
{
if(b==0)
{
x=1;y=0;
return a;//a是最大公约数
}
/*
int temp=x;
x=y;
y=temp-a/b*y;
return ans;
*/
__int64 ans=exgcd(b,a%b,y,x);
y-=a/b*x;
return ans;
}
int main()
{
__int64 a,b,x,y;
while(scanf("%I64d%I64d",&a,&b)!=EOF)
{
__int64 gcd=exgcd(a,b,x,y);
if(gcd==1)
{
x=(x%b+b)%b;
y=(1-a*x)/b;
printf("%I64d %I64d\n",x,y);
}
else printf("sorry\n");
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: