您的位置:首页 > 其它

hdu1232&& hdu1213(简单并查集)

2015-06-04 21:10 211 查看
题目链接:http://acm.hdu.edu.cn/showproblem.php?pid=1232

畅通工程

Time Limit: 4000/2000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)

Total Submission(s): 35673 Accepted Submission(s): 18897



[align=left]Problem Description[/align]
某省调查城镇交通状况,得到现有城镇道路统计表,表中列出了每条道路直接连通的城镇。省政府“畅通工程”的目标是使全省任何两个城镇间都可以实现交通(但不一定有直接的道路相连,只要互相间接通过道路可达即可)。问最少还需要建设多少条道路?

[align=left]Input[/align]
测试输入包含若干测试用例。每个测试用例的第1行给出两个正整数,分别是城镇数目N ( < 1000 )和道路数目M;随后的M行对应M条道路,每行给出一对正整数,分别是该条道路直接连通的两个城镇的编号。为简单起见,城镇从1到N编号。

注意:两个城市之间可以有多条道路相通,也就是说

3 3

1 2

1 2

2 1

这种输入也是合法的

当N为0时,输入结束,该用例不被处理。

[align=left]Output[/align]
对每个测试用例,在1行里输出最少还需要建设的道路数目。

[align=left]Sample Input[/align]

4 2
1 3
4 3
3 3
1 2
1 3
2 3
5 2
1 2
3 5
999 0
0


[align=left]Sample Output[/align]
1
0
2
998


前两天听学长简单的讲了一下并查集,于是找了两个最简单的并查集水题做了一下,依次就ac了,方法效率不高,等过些天深入学习时再修改吧。

【代码如下】

#include <cstdio>
#include <algorithm>
using namespace std;
int f[1010],n;
void connect(int i,int j)  //连接
{
if(f[i]==f[j]) //如果已经连接, 直接返回
return ;
int p=f[i];
int q=f[j];
for(int i=1;i<=n;i++)//将所有和 f[i]相同的元素置为 和f[j]相同,从而实现了联通
{
if(f[i]==p)
f[i]=q;
}
}
int main()
{
int m;
while(scanf("%d",&n)!=EOF&&n)
{
int st;
scanf("%d",&m);
for(int i=1;i<=n;i++)
{
f[i]=i;           //初始化,使得初始状态,每一个占一个集合,都不联通
}
for(int i=0;i<m;i++)
{
int p,q;
scanf("%d%d",&p,&q);
connect(p,q);
}
st=0;
for(int i=1;i<=n;i++)  //查找有多少不同集合就行了,修路的话再-1;
{
if(f[i]==i)
st++;
}
printf("%d\n",st-1);
}
return 0;
}


hdu 1231 题目链接:http://acm.hdu.edu.cn/showproblem.php?pid=1213

How Many Tables

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)

Total Submission(s): 17271 Accepted Submission(s): 8456



[align=left]Problem Description[/align]
Today is Ignatius' birthday. He invites a lot of friends. Now it's dinner time. Ignatius wants to know how many tables he needs at least. You have to notice that not all the friends know each other, and all the friends do not want
to stay with strangers.

One important rule for this problem is that if I tell you A knows B, and B knows C, that means A, B, C know each other, so they can stay in one table.

For example: If I tell you A knows B, B knows C, and D knows E, so A, B, C can stay in one table, and D, E have to stay in the other one. So Ignatius needs 2 tables at least.

[align=left]Input[/align]
The input starts with an integer T(1<=T<=25) which indicate the number of test cases. Then T test cases follow. Each test case starts with two integers N and M(1<=N,M<=1000). N indicates the number of friends, the friends are marked
from 1 to N. Then M lines follow. Each line consists of two integers A and B(A!=B), that means friend A and friend B know each other. There will be a blank line between two cases.

[align=left]Output[/align]
For each test case, just output how many tables Ignatius needs at least. Do NOT print any blanks.

[align=left]Sample Input[/align]

2
5 3
1 2
2 3
4 5

5 1
2 5


[align=left]Sample Output[/align]

2
4


和上一个题目一样,只不过不用减一了,

【代码如下】

#include <iostream>
#include <algorithm>
using namespace std;
int n,k,f[1010];
void connect(int a,int b)
{
if(f[a]==f[b])
return ;
int p=f[a];
int q=f[b];
for(int i=1;i<=n;i++)
if(f[i]==q)
f[i]=p;
}
int main()
{
int t;
cin>>t;
while(t--)
{
cin>>n>>k;
for(int i=1;i<=n;i++)
f[i]=i;
for(int i=0;i<k;i++)
{
int a,b;
cin>>a>>b;
connect(a,b);
}
//   sort(f+1,f+n+1);
int ans=0;
for(int i=1;i<=n;i++)
{
if(f[i]==i)
ans++;
}
cout<<ans<<endl;
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: