您的位置:首页 > 其它

[HDU 1213] How Many Tables

2015-06-04 17:47 162 查看

How Many Tables

Time Limit: 2000/1000 MS (Java/Others)

Memory Limit: 65536/32768 K (Java/Others)

[align=left]Problem Description[/align]
Today is Ignatius' birthday. He invites a lot of friends. Now it's dinner time. Ignatius wants to know how many tables he needs at least. You have to notice that not all the friends know each other, and all the friends do not want to stay with strangers.
One important rule for this problem is that if I tell you A knows B, and B knows C, that means A, B, C know each other, so they can stay in one table.
For example: If I tell you A knows B, B knows C, and D knows E, so A, B, C can stay in one table, and D, E have to stay in the other one. So Ignatius needs 2 tables at least.
[align=left]Input[/align]
The input starts with an integer T(1<=T<=25) which indicate the number of test cases. Then T test cases follow. Each test case starts with two integers N and M(1<=N,M<=1000). N indicates the number of friends, the friends are marked from 1 to N. Then M lines follow. Each line consists of two integers A and B(A!=B), that means friend A and friend B know each other. There will be a blank line between two cases.
[align=left]Output[/align]
For each test case, just output how many tables Ignatius needs at least. Do NOT print any blanks.
[align=left]Sample Input[/align]

2

5 3

1 2

2 3

4 5

5 1

2 5

[align=left]Sample Output[/align]

2
4
【题解】其实就是问有多少个连通块,并查集裸题,练练手。

#include <bits/stdc++.h>
using namespace std;
int pre[1001],r[1001],t,n,m;
int findset(int x) {
int r=x;
while(pre[r]!=r) r=pre[r];
int i=x,j;
while(i!=r) {
j=pre[i];
pre[i]=r;
i=j;
}
return r;
}
void join(int a,int b) {
int f1=findset(a),f2=findset(b);
if(r[f1]<=r[f2]) {
pre[f1]=f2;
if(r[f1]==r[f2]) r[f2]++;
}
else pre[f2]=f1;
}
int main() {
scanf("%d",&t);
while(t--) {
scanf("%d%d",&n,&m);
for (int i=1;i<=n;++i) pre[i]=i,r[i]=1;
while(m--) {
int a,b;
scanf("%d%d",&a,&b);
join(a,b);
}
int cnt=0;
for (int i=1;i<=n;++i) if(i==pre[i]) cnt++;
printf("%d\n",cnt);
}
return 0;
}


View Code
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: