您的位置:首页 > 其它

POJ 3617

2015-06-03 16:16 381 查看
Best Cow Line

Time Limit: 1000MS Memory Limit: 65536K

Total Submissions: 12792 Accepted: 3707

Description

FJ is about to take his N (1 ≤ N ≤ 2,000) cows to the annual"Farmer of the Year" competition. In this contest every farmer arranges his cows in a line and herds them past the judges.

The contest organizers adopted a new registration scheme this year: simply register the initial letter of every cow in the order they will appear (i.e., If FJ takes Bessie, Sylvia, and Dora in that order he just registers BSD). After the registration phase
ends, every group is judged in increasing lexicographic order according to the string of the initials of the cows' names.

FJ is very busy this year and has to hurry back to his farm, so he wants to be judged as early as possible. He decides to rearrange his cows, who have already lined up, before registering them.

FJ marks a location for a new line of the competing cows. He then proceeds to marshal the cows from the old line to the new one by repeatedly sending either the first or last cow in the (remainder of the) original line to the end of the new line. When he's
finished, FJ takes his cows for registration in this new order.

Given the initial order of his cows, determine the least lexicographic string of initials he can make this way.

Input

* Line 1: A single integer: N

* Lines 2..N+1: Line i+1 contains a single initial ('A'..'Z') of the cow in the ith position in the original line

Output

The least lexicographic string he can make. Every line (except perhaps the last one) contains the initials of 80 cows ('A'..'Z') in the new line.

Sample Input

6

A

C

D

B

C

B

Sample Output

ABCBCD

注意字母是一个一个读进去的,输出要求是每行80个字母,如果n大于80的时候要考虑换行,从字符串的两端开始选出字典序小的,如果两端相等,就往中间查找,直到查找到中间位置的一对能比较出大小的时候,如果给出的是一个回文字符串,也就是说一直找到最中间相连的时候,还不能分辨出大小,就随便输出一个端,这里我输出的的是pre。写错了好多时候,还得多加练习。

#include <iostream>
#include <cstring>
#include <cstdio>
using namespace std;
char c[2005];
int main(void)
{
// freopen("A.txt","r",stdin);
int n;
scanf("%d",&n);
for(int i=1;i<=n;i++)
{
getchar();
scanf("%c",&c[i]);
}
int pre=1,last=n,count=0;
for(int i=1;i<=n;i++)
{
if(c[pre]==c[last])
{
int flag=0;
int pr=pre,la=last;
while(pr<=la)
{
if(c[pr]<c[la])
{
count++;
flag=1;
printf("%c",c[pre++]);
break;
}
else if(c[pr]>c[la])
{
count++;
flag=1;
printf("%c",c[last--]);
break;
}
pr++;
la--;

}
if(flag==0)
{
printf("%c",c[pre++]);
count++;
}
}
else if(c[pre]<c[last])
{
printf("%c",c[pre++]);
count++;
}
else
{
printf("%c",c[last--]);
count++;
}
if(count==80)
{
printf("\n");
count=0;
}
}
if(count)
printf("\n");

return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: