您的位置:首页 > 其它

hdu 1789 排序+数组标记

2015-06-03 00:13 267 查看
<h1 style="color: rgb(26, 92, 200);">Doing Homework again</h1><strong><span style="color: green; font-family: Arial; font-size: 12px;">Time Limit: 1000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 8329    Accepted Submission(s): 4899
</span></strong>

<div align="left" class="panel_title">Problem Description</div><div class="panel_content">Ignatius has just come back school from the 30th ACM/ICPC. Now he has a lot of homework to do. Every teacher gives him a deadline of handing in the homework. If Ignatius hands in the homework after the deadline, the teacher will reduce his score of the final test. And now we assume that doing everyone homework always takes one day. So Ignatius wants you to help him to arrange the order of doing homework to minimize the reduced score. </div><div class="panel_bottom"> </div>
<div align="left" class="panel_title">Input</div><div class="panel_content">The input contains several test cases. The first line of the input is a single integer T that is the number of test cases. T test cases follow.
Each test case start with a positive integer N(1<=N<=1000) which indicate the number of homework.. Then 2 lines follow. The first line contains N integers that indicate the deadlines of the subjects, and the next line contains N integers that indicate the reduced scores.
</div><div class="panel_bottom"> </div>
<div align="left" class="panel_title">Output</div><div class="panel_content">For each test case, you should output the smallest total reduced score, one line per test case.
</div><div class="panel_bottom"> </div>
<div align="left" class="panel_title">Sample Input</div><div class="panel_content"><pre><div style="font-family: Courier New,Courier,monospace;">3
3
3 3 3
10 5 1
3
1 3 1
6 2 3
7
1 4 6 4 2 4 3
3 2 1 7 6 5 4</div>




Sample Output
0
3
5



分析:肯定先按分数排序,然后从头开始,每次肯定要把时间从后往前排,就是说要先用后面几天,如果某一天用了,标记一下。
如果都用了,这一项就完不成了,然后加起来。
#include<iostream>
#include<algorithm>
#include<stdio.h>
#include<cstring>
using namespace std;
struct M{int x;int y;};
M a[1001];int b[1001];
bool cmp(M s,M ss)
{
    if(s.y==ss.y)return s.x<ss.x;
    return s.y>ss.y;
}
int main()
{
    int T,n;
    scanf("%d",&T);
    while(T--)
    {
        cin>>n;
        for(int i=1;i<=n;i++)
            cin>>a[i].x;
        for(int i=1;i<=n;i++)
            cin>>a[i].y;
        sort(a+1,a+1+n,cmp);
        int num=1,sum=0,j;
        memset(b,0,sizeof(b));
       for(int i=1;i<=n;i++)
       {
           for( j=a[i].x;j>=1;j--)
            if(!b[j])
           {
               b[j]=1;break;
           }
           if(j==0)sum+=a[i].y;
       }
        cout<<sum<<endl;
    }
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: