您的位置:首页 > 其它

Sudoku Killer

2015-06-02 16:16 218 查看
题目链接

Sudoku Killer
Time Limit:1000MS Memory Limit:32768KB 64bit IO Format:%I64d
& %I64u
Submit Status Practice HDU
1426

Appoint description:
System Crawler (2015-06-01)

Description

自从2006年3月10日至11日的首届数独世界锦标赛以后,数独这项游戏越来越受到人们的喜爱和重视。

据说,在2008北京奥运会上,会将数独列为一个单独的项目进行比赛,冠军将有可能获得的一份巨大的奖品―――HDU免费七日游外加lcy亲笔签名以及同hdu acm team合影留念的机会。

所以全球人民前仆后继,为了奖品日夜训练茶饭不思。当然也包括初学者linle,不过他太笨了又没有多少耐性,只能做做最最基本的数独题,不过他还是想得到那些奖品,你能帮帮他吗?你只要把答案告诉他就可以,不用教他是怎么做的。

数独游戏的规则是这样的:在一个9x9的方格中,你需要把数字1-9填写到空格当中,并且使方格的每一行和每一列中都包含1-9这九个数字。同时还要保证,空格中用粗线划分成9个3x3的方格也同时包含1-9这九个数字。比如有这样一个题,大家可以仔细观察一下,在这里面每行、每列,以及每个3x3的方格都包含1-9这九个数字。

例题:



答案:





Input

本题包含多组测试,每组之间由一个空行隔开。每组测试会给你一个 9*9 的矩阵,同一行相邻的两个元素用一个空格分开。其中1-9代表该位置的已经填好的数,问号(?)表示需要你填的数。



Output

对于每组测试,请输出它的解,同一行相邻的两个数用一个空格分开。两组解之间要一个空行。

对于每组测试数据保证它有且只有一个解。



Sample Input

7 1 2 ? 6 ? 3 5 8
? 6 5 2 ? 7 1 ? 4
? ? 8 5 1 3 6 7 2
9 2 4 ? 5 6 ? 3 7
5 ? 6 ? ? ? 2 4 1
1 ? 3 7 2 ? 9 ? 5
? ? 1 9 7 5 4 8 6
6 ? 7 8 3 ? 5 1 9
8 5 9 ? 4 ? ? 2 3




Sample Output

7 1 2 4 6 9 3 5 8
3 6 5 2 8 7 1 9 4
4 9 8 5 1 3 6 7 2
9 2 4 1 5 6 8 3 7
5 7 6 3 9 8 2 4 1
1 8 3 7 2 4 9 6 5
2 3 1 9 7 5 4 8 6
6 4 7 8 3 2 5 1 9
8 5 9 6 4 1 7 2 3


#include<iostream>
#include<cstdio>
#include<string>
#include<cstring>
#include<vector>
#include<cmath>
#include<queue>
#include<stack>
#include<map>
#include<set>
#include<algorithm>

using namespace std;
const int maxn=100010;
const int INF=1000000100;
const int dir1[4][2] = {{1, 1}, {1, -1}, {-1, 1}, {-1, -1}};
const int dir2[4][2] = {{0, 1}, {0, -1}, {0, 1}, {0, -1}};
const int dir3[4][2] = {{1, 0}, {1, 0}, {-1, 0}, {-1, 0}};

#define PI acos-1.0
#define N 510

char g

;
int k, flag, vis
;

void DFS (int n);
void Print ();
int check (int x, int y, int i);

int main ()
{
    int i, j, p = 0;
    while (cin >> g[0][0])
    {
        k = 0, flag = 0;
        if (p++)
            cout << endl;
        memset (vis, 0, sizeof (vis));
        if (g[0][0] == '?')
            vis[k++] = 0;

        for (i=0; i<9; i++)
        {
            for (j=0; j<9; j++)
            {
                if (i || j)
                {
                    cin >> g[i][j];
                    if (g[i][j] == '?')
                        vis[k++] = i * 9 + j;
                }
            }
        }
        DFS (0);
    }
    return 0;
}

void DFS (int n)
{
    if (n >= k)
    {
        flag = 1;
        Print ();
        return;
    }

    int x = vis
/9, y = vis
%9;

    for (int i=1; i<=9; i++)
    {
        if (check (x, y, i))
        {
            g[x][y] = i + '0';
            DFS (n+1);
            if (flag)
                return;
            g[x][y] = '?';
        }
    }
}

int check (int x, int y, int i)
{
    for (int j=0; j<9; j++)
        if (g[x][j] == i + '0' || g[j][y] == i + '0')
            return 0;

    int dx = x / 3, dy = y / 3;

    for (int j=dx*3; j<dx*3+3; j++)
        for (int j1=dy*3; j1<dy*3+3; j1++)
            if (g[j][j1] == i + '0')
                return 0;
    return 1;
}

void Print ()
{
    for (int i=0; i<9; i++)
    {
        for (int j=0; j<8; j++)
            cout << g[i][j] << ' ';
        cout << g[i][8] << endl;
    }
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: