您的位置:首页 > 产品设计 > UI/UE

01-复杂度2. Maximum Subsequence Sum (25)

2015-06-01 10:11 459 查看


01-复杂度2. Maximum Subsequence Sum (25)

时间限制

400 ms

内存限制

65536 kB

代码长度限制

8000 B

判题程序

Standard

作者

CHEN, Yue

Given a sequence of K integers { N1, N2, ..., NK }. A continuous subsequence is defined to be { Ni, Ni+1,
..., Nj } where 1 <= i <= j <= K. The Maximum Subsequence is the continuous subsequence which has the largest sum of its elements. For example, given sequence { -2, 11, -4, 13, -5, -2 }, its maximum subsequence is
{ 11, -4, 13 } with the largest sum being 20.

Now you are supposed to find the largest sum, together with the first and the last numbers of the maximum subsequence.

Input Specification:

Each input file contains one test case. Each case occupies two lines. The first line contains a positive integer K (<= 10000). The second line contains K numbers, separated by a space.

Output Specification:

For each test case, output in one line the largest sum, together with the first and the last numbers of the maximum subsequence. The numbers must be separated by one space, but there must be no extra space at the end of a line. In case that the maximum subsequence
is not unique, output the one with the smallest indices i and j (as shown by the sample case). If all the K numbers are negative, then its maximum sum is defined to be 0, and you are supposed to output the first and the last numbers of the whole sequence.
Sample Input:
10
-10 1 2 3 4 -5 -23 3 7 -21

Sample Output:
10 1 4


提交代

在前一题01-复杂度1. 最大子列和问题(20) 基础上的第二种方法上更改的。加了flag1,flag2,作为标志,分别记录i,j的值,如果之后max没有更改过了,i,j就是最小的i,j

即能保证,数列不唯一时,根据最小i、j输出对应的最大子列和。

/*最大子列和*/
#include <iostream>
#define maxsize 100000+100
using namespace std;

int A[maxsize];
int S[maxsize];
int main(){
int K,i,j,max=0,tmp,cnt=0,flag1,flag2;
cin>>K;
for(i=1;i<=K;i++){
cin>>A[i];
}
S[0]=0;
for(i=1;i<=K;i++){
if(A[i]<0)
cnt++;
S[i]=S[i-1]+A[i];
}
if(cnt==K){
cout<<"0"<<" "<<A[1]<<" "<<A[K]<<endl;
return 0;
}
for(i=1;i<=K;i++)
for(j=i;j<=K;j++){
tmp=S[j]-S[i-1];
if(tmp>max){
max=tmp;
flag1=i;
flag2=j;
}
}
cout<<max<<" "<<A[flag1]<<" "<<A[flag2]<<endl;
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: