您的位置:首页 > 其它

poj 2104 区间第K小 主席树入门题

2015-05-21 10:31 465 查看
K-th Number

Time Limit: 20000MSMemory Limit: 65536K
Total Submissions: 40933Accepted: 13377
Case Time Limit: 2000MS
Description
You are working for Macrohard company in data structures department. After failing your previous task about key insertion you were asked to write a new data structure that would be able to return quickly k-th order statistics in
the array segment.

That is, given an array a[1...n] of different integer numbers, your program must answer a series of questions Q(i, j, k) in the form: "What would be the k-th number in a[i...j] segment, if this segment was sorted?"

For example, consider the array a = (1, 5, 2, 6, 3, 7, 4). Let the question be Q(2, 5, 3). The segment a[2...5] is (5, 2, 6, 3). If we sort this segment, we get (2, 3, 5, 6), the third number is 5, and therefore the answer to the question is 5.

Input
The first line of the input file contains n --- the size of the array, and m --- the number of questions to answer (1 <= n <= 100 000, 1 <= m <= 5 000).

The second line contains n different integer numbers not exceeding 109 by their absolute values --- the array for which the answers should be given.

The following m lines contain question descriptions, each description consists of three numbers: i, j, and k (1 <= i <= j <= n, 1 <= k <= j - i + 1) and represents the question Q(i, j, k).

Output
For each question output the answer to it --- the k-th number in sorted a[i...j] segment.

Sample Input
7 3
1 5 2 6 3 7 4
2 5 3
4 4 1
1 7 3

Sample Output
5
6
3

#include <iostream>
#include<stdio.h>
#include<string.h>
#include<algorithm>
using namespace std;
const int maxn=100010;
const int M=maxn*30;
int n,q,m,tot;
int a[maxn],t[maxn];
int T[M],lson[M],rson[M],c[M];
void init_hash()//离散化
{
for(int i=1;i<=n;i++)
t[i]=a[i];
sort(t+1,t+1+n);
m=unique(t+1,t+1+n)-t-1;

}
int hash(int x)
{
return lower_bound(t+1,t+1+m,x) - t;
}
int build(int l,int r)//建树
{
int root=tot++;
c[root]=0;
if(l!=r)
{
int mid=(l+r)>>1;
lson[root]=build(l,mid);
rson[root]=build(mid+1,r);
}
return root;
}
int update(int root,int pos,int val)
{
int newroot=tot++,tmp=newroot;
c[newroot]=c[root]+val;
int l=1,r=m;
while(l<r)
{
int mid=(l+r)>>1;
if(pos<=mid)
{
lson[newroot]=tot++;rson[newroot]=rson[root];
newroot=lson[newroot];root=lson[root];
r=mid;
}
else
{
rson[newroot]=tot++;lson[newroot]=lson[root];
newroot=rson[newroot];root=rson[root];
l=mid+1;
}
c[newroot]=c[root]+val;
}
return tmp;

}
int query(int left_root,int right_root,int k)
{
int l=1,r=m;
while(l<r)
{
int mid=(l+r)>>1;
if(c[lson[left_root]]-c[lson[right_root]] >= k)//区间第K小
{
r=mid;
left_root=lson[left_root];
right_root=lson[right_root];
}
else
{
l=mid+1;
k-=c[lson[left_root]]-c[lson[right_root]];
left_root=rson[left_root];
right_root=rson[right_root];
}
}
return l;
}
int main()
{
while(scanf("%d%d",&n,&q)==2)
{
tot=0;
for(int i=1;i<=n;i++)
scanf("%d",&a[i]);
init_hash();
T[n+1]=build(1,m);
for(int i=n;i;i--)
{
int pos=hash(a[i]);
T[i]=update(T[i+1],pos,1);
}
while(q--)
{
int l,r,k;
scanf("%d%d%d",&l,&r,&k);
printf("%d\n",t[query(T[l],T[r+1],k)]);
}
}

}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: