您的位置:首页 > Web前端

HDU-1015-Safecracker(Java && 暴力大法好 && 简单字典序)

2015-05-13 23:14 225 查看


Safecracker

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)

Total Submission(s): 9965 Accepted Submission(s): 5097



Problem Description

=== Op tech briefing, 2002/11/02 06:42 CST ===

"The item is locked in a Klein safe behind a painting in the second-floor library. Klein safes are extremely rare; most of them, along with Klein and his factory, were destroyed in World War II. Fortunately old Brumbaugh from research knew Klein's secrets and
wrote them down before he died. A Klein safe has two distinguishing features: a combination lock that uses letters instead of numbers, and an engraved quotation on the door. A Klein quotation always contains between five and twelve distinct uppercase letters,
usually at the beginning of sentences, and mentions one or more numbers. Five of the uppercase letters form the combination that opens the safe. By combining the digits from all the numbers in the appropriate way you get a numeric target. (The details of constructing
the target number are classified.) To find the combination you must select five letters v, w, x, y, and z that satisfy the following equation, where each letter is replaced by its ordinal position in the alphabet (A=1, B=2, ..., Z=26). The combination is then
vwxyz. If there is more than one solution then the combination is the one that is lexicographically greatest, i.e., the one that would appear last in a dictionary."

v - w^2 + x^3 - y^4 + z^5 = target

"For example, given target 1 and letter set ABCDEFGHIJKL, one possible solution is FIECB, since 6 - 9^2 + 5^3 - 3^4 + 2^5 = 1. There are actually several solutions in this case, and the combination turns out to be LKEBA. Klein thought it was safe to encode
the combination within the engraving, because it could take months of effort to try all the possibilities even if you knew the secret. But of course computers didn't exist then."

=== Op tech directive, computer division, 2002/11/02 12:30 CST ===

"Develop a program to find Klein combinations in preparation for field deployment. Use standard test methodology as per departmental regulations. Input consists of one or more lines containing a positive integer target less than twelve million, a space, then
at least five and at most twelve distinct uppercase letters. The last line will contain a target of zero and the letters END; this signals the end of the input. For each line output the Klein combination, break ties with lexicographic order, or 'no solution'
if there is no correct combination. Use the exact format shown below."

Sample Input

1 ABCDEFGHIJKL
11700519 ZAYEXIWOVU
3072997 SOUGHT
1234567 THEQUICKFROG
0 END


Sample Output

LKEBA
YOXUZ
GHOST
no solution


Source

Mid-Central USA 2002

Recommend

JGShining | We have carefully selected several similar problems for you: 1010 1016 1239 1238 1072

看着这么长的英文,亚历山大!!但是它说了这么长要表达的意思其实很简单!

就是给定一个目标数字target,再给你一个备选字符串(5~12个字符),要你从这个备选字符串(字符串全都有大写字母构成)中选5个字符出来,满足题目给出的等式——v - w^2 + x^3 - y^4 + z^5 = target (v,w,x,y,z分别表示这个选取的5个字符的数字序号,‘A’=1,'B=2'依次类推)

并且选择的这5个字符串必须是所有可能情况中按照字典序最大的情况

简单分析下就可以看出,就是一个组合问题,问题解的最大规模就是12取5,就是12*11*10*9*8*7,而最小规模是5取5,所以应该用枚举法就可以搞定。不过,枚举之前先排个序,就可以保证输出的是符合要求的最大的那个了

//暴力水过!简单的字典序问题弄了菜鸟博主半个多小时!

import java.io.*;
import java.util.*;

public class Main
{

public static void main(String[] args)
{
// TODO Auto-generated method stub
Scanner input = new Scanner(System.in);
while (input.hasNext())
{
int target = input.nextInt();
boolean flag = false;
String str = input.nextLine();
str = str.replaceAll(" ", "");                            //去掉字符串前面的空格
if (target == 0 && str.compareTo("END") == 0)             //如果满足条件中止程序
break;
char c[] = str.toCharArray();                             //字符串转换为字符数组
int a[] = new int[str.length()];
for (int i = 0; i < c.length; i++)
{
a[i] = CMP(c[i]);                                    //字符数组转换为数字数组
}
Arrays.sort(a);                                          //快速排序方法,但是此时数组顺序是从小到大
for (int i = c.length - 1; i >= 0; i--)
{
for (int j = c.length - 1; j >= 0; j--)
{
if (j == i)
continue;
for (int k = c.length - 1; k >= 0; k--)
{
if (k == i || k == j)
continue;
for (int l = c.length - 1; l >= 0; l--)
{
if (l == i || l == j || l == k)
continue;
for (int m = c.length - 1; m >= 0; m--)
{
if (m == i || m == j || m == k || m == l)
continue;
if ((a[i] - (a[j] * a[j])                                    //代入公式求解
+ (a[k] * a[k] * a[k])
- (a[l] * a[l] * a[l] * a[l])
+ (a[m]* a[m] * a[m] * a[m] * a[m])) == target)
{
flag = true;
char c1 = (char) (a[i] + 'A' - 1);
char c2 = (char) (a[j] + 'A' - 1);
char c3 = (char) (a[k] + 'A' - 1);
char c4 = (char) (a[l] + 'A' - 1);
char c5 = (char) (a[m] + 'A' - 1);
System.out.println(c1 + "" + c2 + "" + c3 + "" + c4 + "" + c5);
break;
}
}
if (flag)
break;
}
if (flag)
break;
}
if (flag)
break;
}
if (flag)
break;
}
if (!flag)
System.out.println("no solution");
}
}

public static int CMP(char c)
{
return ((c - 'A') + 1);                                                  //A字符代表的数字符号是1
}

}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: