您的位置:首页 > 其它

HDU 4605 Magic Ball Game

2015-05-13 15:17 323 查看


Font Size: ← →


Problem Description

When the magic ball game turns up, Kimi immediately falls in it. The interesting game is made up of N balls, each with a weight of w[i]. These N balls form a rooted tree, with the 1st ball as the root. Any ball in the game has either 0 or 2 children ball. If
a node has 2 children balls, we may define one as the left child and the other as the right child.

The rules are simple: when Kimi decides to drop a magic ball with a weight of X, the ball goes down through the tree from the root. When the magic ball arrives at a node in the tree, there's a possibility to be catched and stop rolling, or continue to roll
down left or right. The game ends when the ball stops, and the final score of the game depends on the node at which it stops.

After a long-time playing, Kimi now find out the key of the game. When the magic ball arrives at node u weighting w[u], it follows the laws below:

1 If X=w[u] or node u has no children balls, the magic ball stops.

2 If X<w[u], there's a possibility of 1/2 for the magic ball to roll down either left or right.

3 If X>w[u], the magic ball will roll down to its left child in a possibility of 1/8, while the possibility of rolling down right is 7/8.

In order to choose the right magic ball and achieve the goal, Kimi wonders what's the possibility for a magic ball with a weight of X to go past node v. No matter how the magic ball rolls down, it counts if node v exists on the path that the magic ball goes
along.

Manual calculating is fun, but programmers have their ways to reach the answer. Now given the tree in the game and all Kimi's queries, you're required to answer the possibility he wonders.


Input

The input contains several test cases. An integer T(T≤15) will exist in the first line of input, indicating the number of test cases.

Each test case begins with an integer N(1≤N≤105), indicating the number of nodes in the tree. The following line contains N integers w[i], indicating the weight of each node in the tree. (1 ≤ i ≤ N, 1 ≤ w[i] ≤ 109, N is odd)

The following line contains the number of relationships M. The next M lines, each with three integers u,a and b(1≤u,a,b≤N), denotes that node a and b are respectively the left child and right child of node u. You may assume the tree contains exactly N nodes
and (N-1) edges.

The next line gives the number of queries Q(1≤Q≤105). The following Q lines, each with two integers v and X(1≤v≤N,1≤X≤109), describe all the queries.


Output

If the magic ball is impossible to arrive at node v, output a single 0. Otherwise, you may easily find that the answer will be in the format of 7x/2y . You're only required to output the x and y for each query, separated by a blank. Each
answer should be put down in one line.


Sample Input

1
3
2 3 1
1
1 2 3
3
3 2
1 1
3 4



Sample Output

0
0 0
1 3

离线+dfs+线段树。
#pragma comment(linker, "/STACK:1024000000,1024000000") 
#include<cstdio>
#include<cmath>
#include<queue>
#include<map>
#include<vector>
#include<string>
#include<cstring>
#include<iostream>
#include<algorithm>
using namespace std;
const int maxn = 100005;
map<int, int> M;
map<int, int> ::iterator u;
vector<int> t[maxn];
int T, n, w[maxn], m, x, y, z, f[2][maxn * 4], N, NN;

struct abc
{
	int v, id;
	abc(){};
	abc(int v, int id) :v(v), id(id){};
}a[maxn];
vector<abc> p[maxn];

void init()
{
	scanf("%d", &n);
	
	memset(f, 0, sizeof(f));
	M.clear();
	for (int i = 1; i <= n; i++)
	{
		scanf("%d", &w[i]);
		M[w[i]] = 1;
		t[i].clear();
		p[i].clear();
	}

	scanf("%d", &n);
	while (n--)
	{
		scanf("%d%d%d", &x, &y, &z);
		t[x].push_back(y);
		t[x].push_back(z);
	}

	scanf("%d", &n);
	for (int i = 0; i < n; i++)
	{
		scanf("%d%d", &x, &y);
		M[y] = 1;
		p[x].push_back(abc(y, i));
	}
	for (NN = 1, u = M.begin(); u != M.end(); u++) u->second = NN++;
	for (N = 1; N < NN; N += N);
}

void insert(int z, int x, int y)
{
	for (int i = x + N; i; i >>= 1) f[z][i] += y;
}

int get(int z, int l, int r)
{
	int tot = 0;
	for (l += N - 1, r += N + 1; r ^ l ^ 1; l >>= 1, r >>= 1)
	{
		if (~l & 1) tot += f[z][l ^ 1];
		if (r & 1) tot += f[z][r ^ 1];
	}
	return tot;
}

void dfs(int x)
{
	for (int i = 0, j; i < p[x].size(); i++)
	{
		j = M[p[x][i].v];
		if (get(0, j, j) || get(1, j, j)) a[p[x][i].id].v = -1;
		else
		{
			a[p[x][i].id].v = get(1, 1, j);
			a[p[x][i].id].id = get(1, j, NN) + get(0, j, NN) + 3 * (get(0, 1, j) + get(1, 1, j));
		}
	}
	for (int i = 0; i < t[x].size(); i++)
	{
		insert(i, M[w[x]], 1);
		dfs(t[x][i]);
		insert(i, M[w[x]], -1);
	}
	
}

int main()
{
	scanf("%d", &T);
	while (T--)
	{
		init();		dfs(1);
		for (int i = 0; i < n; i++)
		{
			if (a[i].v < 0) puts("0");
			else printf("%d %d\n", a[i].v, a[i].id);
		}
	}
	return 0;
}


内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: