您的位置:首页 > 其它

HDU2051 10进制转化成2进制

2015-05-03 23:14 225 查看

Bitset

Time Limit: 1000/1000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)

Total Submission(s): 15401 Accepted Submission(s): 11684



Problem Description
Give you a number on base ten,you should output it on base two.(0 < n < 1000)


Input
For each case there is a postive number n on base ten, end of file.


Output
For each case output a number on base two.


Sample Input
1
2
3




Sample Output
1
10
11




Author
8600 && xhd

#include<stdio.h>
void exchang(int x)
{
	int a[11]={0},n=-1,i;
	while(x)
	{
		n++;
		a
=x%2;
		x=x/2;
	}
	for(i=n;i>-1;i--)
		printf("%d",a[i]);
}

int main()
{
	int x;
	while(scanf("%d",&x)!=EOF)
	{
		exchang(x);
		printf("\n");
	}
	return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: