您的位置:首页 > 其它

poj3083 Children of the Candy Cor

2015-05-02 14:02 274 查看
Description

The cornfield maze is a popular Halloween treat. Visitors are shown the entrance and must wander through the maze facing zombies, chainsaw-wielding psychopaths, hippies, and other terrors on their quest to find the exit.

One popular maze-walking strategy guarantees that the visitor will eventually find the exit. Simply choose either the right or left wall, and follow it. Of course, there's no guarantee which strategy (left or right) will be better, and the path taken is seldom
the most efficient. (It also doesn't work on mazes with exits that are not on the edge; those types of mazes are not represented in this problem.)

As the proprieter of a cornfield that is about to be converted into a maze, you'd like to have a computer program that can determine the left and right-hand paths along with the shortest path so that you can figure out which layout has the best chance of confounding
visitors.
Input

Input to this problem will begin with a line containing a single integer n indicating the number of mazes. Each maze will consist of one line with a width, w, and height, h (3 <= w, h <= 40), followed by h lines of w characters each that represent the maze
layout. Walls are represented by hash marks ('#'), empty space by periods ('.'), the start by an 'S' and the exit by an 'E'.

Exactly one 'S' and one 'E' will be present in the maze, and they will always be located along one of the maze edges and never in a corner. The maze will be fully enclosed by walls ('#'), with the only openings being the 'S' and 'E'. The 'S' and 'E' will also
be separated by at least one wall ('#').

You may assume that the maze exit is always reachable from the start point.
Output

For each maze in the input, output on a single line the number of (not necessarily unique) squares that a person would visit (including the 'S' and 'E') for (in order) the left, right, and shortest paths, separated by a single space each. Movement from one
square to another is only allowed in the horizontal or vertical direction; movement along the diagonals is not allowed.
Sample Input
2
8 8
########
#......#
#.####.#
#.####.#
#.####.#
#.####.#
#...#..#
#S#E####
9 5
#########
#.#.#.#.#
S.......E
#.#.#.#.#
#########

Sample Output
37 5 5
17 17 9

这道题求最短路可以用bfs,但是求绕墙走的时间时不用搜索,因为一定只有唯一的一条路,绕墙走有优先考虑左边和右边两种情况,考虑左边的时候,如果能往左走就往做,否则再考虑能不能向前走,即按原来的方向,如果也不行,再看能不能往右走,如果三种情况都不行,就往后走,这里要开一个数组记录方向。

#include<stdio.h>
#include<string.h>
#include<math.h>
char map[45][45];
int tab[8][2]={0,0,0,1,-1,0,0,-1,1,0},dir,b[45][45];
int q[1111111][2],x3,y3,x2,y2,n,m;

void bfs()
{
	memset(q,0,sizeof(q));
	memset(b,0,sizeof(b));
	b[x2][y2]=1;
	int front=1,rear=1,xx,yy,i,x,y;
	q[front][0]=x2;q[front][1]=y2;
	while(front<=rear){
		x=q[front][0];
		y=q[front][1];
		if(x==x3 && y==y3)break;
		front++;
		for(i=1;i<=4;i++){
			xx=x+tab[i][0];yy=y+tab[i][1];
			if(xx>=0 && xx<m && yy>=0 && yy<n && map[xx][yy]!='#'){
				map[xx][yy]='#';
				b[xx][yy]=b[x][y]+1;
				rear++;
				q[rear][0]=xx;
				q[rear][1]=yy;
			}
		}
	}
	return ;
}

int main()
{
	int T,i,j,num1,num2,num3,x,y,dir1,xx,yy,dir2;
	scanf("%d",&T);
	while(T--)
    {
    	scanf("%d%d",&n,&m);
    	for(i=0;i<m;i++){
	    	scanf("%s",map[i]);
	    	for(j=0;j<n;j++){
	    		if(map[i][j]=='S'){
		    		x2=i;y2=j;
		    	}
		    	else if(map[i][j]=='E'){
	    			x3=i;y3=j;
	    		}
	    	}
	    }
	    if(y2==1)dir=1;
	    else if(x2==m)dir=2;
	    else if(y2==n)dir=3;
	    else if(x2==1)dir=4;
	    num1=0;
	    
	    
	    memset(b,0,sizeof(b));
	    x=x2,y=y2,num1=1,dir1=dir;
	    while(1)
	    {
			if(x==x3 && y==y3)break;
			num1++;
			//printf("%d %d\n",x+1,y+1);
    		xx=x+tab[dir1%4+1][0];
    		yy=y+tab[dir1%4+1][1];
			if(xx>=0 && xx<m && yy>=0 && yy<n && map[xx][yy]!='#'){
    			x=xx;y=yy;
				dir1=dir1%4+1;continue;
		    }
		    
		    xx=x+tab[dir1][0];
		    yy=y+tab[dir1][1];
		    if(xx>=0 && xx<m && yy>=0 && yy<n && map[xx][yy]!='#'){
    			x=xx;y=yy;continue;
    		}
    		
    		xx=x+tab[(dir1==1)?4:(dir1-1)][0];
    		yy=y+tab[(dir1==1)?4:(dir1-1)][1];
    		if(xx>=0 && xx<m && yy>=0 && yy<n && map[xx][yy]!='#'){
    			x=xx;y=yy;
				dir1=(dir1==1?4:(dir1-1));continue;
		    }
		    
		    
		    dir1=(dir1+1)%4+1;
		    x=x+tab[dir1][0];
		    y=y+tab[dir1][1];
		    
    	}
    	//printf("%d\n",num1);
    	
    	memset(b,0,sizeof(b));
	    x=x2,y=y2,num2=1,dir2=dir;
	    while(1)
	    {
    		
			if(x==x3 && y==y3)break;
			num2++;
			//printf("%d %d\n",x+1,y+1);
			
			xx=x+tab[(dir2==1)?4:(dir2-1)][0];
    		yy=y+tab[(dir2==1)?4:(dir2-1)][1];
    		if(xx>=0 && xx<m && yy>=0 && yy<n && map[xx][yy]!='#'){
    			x=xx;y=yy;
				dir2=(dir2==1?4:(dir2-1));continue;
		    }
		    
    		xx=x+tab[dir2][0];
		    yy=y+tab[dir2][1];
		    if(xx>=0 && xx<m && yy>=0 && yy<n && map[xx][yy]!='#'){
    			x=xx;y=yy;continue;
    		}
		    
			xx=x+tab[dir2%4+1][0];
    		yy=y+tab[dir2%4+1][1];
			if(xx>=0 && xx<m && yy>=0 && yy<n && map[xx][yy]!='#'){
    			x=xx;y=yy;
				dir2=dir2%4+1;continue;
		    }
		    dir2=(dir2+1)%4+1;
		    x=x+tab[dir2][0];
		    y=y+tab[dir2][1];
		    
    	}
    	map[x2][y2]='#';
	    bfs();
	    num3=b[x3][y3];
	    printf("%d %d %d\n",num1,num2,num3);
    }
    return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: