您的位置:首页 > 其它

杭电 HDU ACM 2199 Can you solve this equation?

2015-05-01 10:01 309 查看

Can you solve this equation?

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)

Total Submission(s): 11180 Accepted Submission(s): 5151



Problem Description
Now,given the equation 8*x^4 + 7*x^3 + 2*x^2 + 3*x + 6 == Y,can you find its solution between 0 and 100;

Now please try your lucky.


Input
The first line of the input contains an integer T(1<=T<=100) which means the number of test cases. Then T lines follow, each line has a real number Y (fabs(Y) <= 1e10);


Output
For each test case, you should just output one real number(accurate up to 4 decimal places),which is the solution of the equation,or “No solution!”,if there is no solution for the equation between 0 and 100.


Sample Input
2
100
-4




Sample Output
1.6152
No solution!




Author
Redow


搜索题,嗯, 这次知道了有个搜索名次,二分搜索。这样查找答案确实感觉特别妙。low 和high 无限夹逼答案。所以因为最后结果只需满足一定的精确度。这样可以找到合适的条件跳出while。
唉,如果不知道这样的话,浮点数暴力简直无语了都。
#include<iostream>
#include<cmath>
#include<stdio.h>
using namespace std;
double A(double x)
{
    return (8*pow(x,4)+7*pow(x,3)+2*pow(x,2)+3*pow(x,1)+6);
}
int main()
{
    double  y;
    int T;
        cin>>T;
    while(T--)
    {
        cin>>y;
        if(A(0)>y||A(100)<y)
        {
            cout<<"No solution!"<<endl;
            continue;
        }
        else{
                double high,low,mid;
        high=100;
        low=0;
            while(low+1e-8<high)
            {
                mid=(high+low)/2;
                if(A(mid)>y)
                    high=mid;
                else
                    low=mid;
            }
          printf("%.4lf\n",low);
        }
    }
    return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: