您的位置:首页 > 其它

zjuoj The 12th Zhejiang Provincial Collegiate Programming Contest Ace of Aces

2015-04-25 20:12 483 查看
http://acm.zju.edu.cn/onlinejudge/showContestProblem.do?problemId=5493

                        The 12th Zhejiang Provincial Collegiate Programming Contest - A

Ace of AcesTime Limit: 2 Seconds Memory Limit: 65536 KB
There is a mysterious organization called Time-Space Administrative Bureau (TSAB) in the deep universe that we humans have not discovered yet. This year, the TSAB decided to elect an outstanding member from its elite troops. The elected guy will be honored with the title of "Ace of Aces".

After voting, the TSAB received N valid tickets. On each ticket, there is a number Ai denoting the ID of a candidate. The candidate with the most tickets nominated will be elected as the "Ace of Aces". If there are two or more candidates have the same number of nominations, no one will win.

Please write program to help TSAB determine who will be the "Ace of Aces".

Input

There are multiple test cases. The first line of input contains an integer T indicating the number of test cases. For each test case:

The first line contains an integer N (1 <= N <= 1000). The next line contains N integers Ai (1 <= Ai <= 1000).

Output

For each test case, output the ID of the candidate who will be honored with "Ace of Aces". If no one win the election, output "Nobody" (without quotes) instead.

Sample Input

3
5
2 2 2 1 1
5
1 1 2 2 3
1
998

Sample Output

2
Nobody
998

分析:
这道题应该是这次浙江省acm省赛的签到题了.
就是比较整数数组元素出现次数最多的一个,如果有多个 输出 Nobody

AC代码:


#include <stdio.h>
#include <algorithm>
#include <iostream>
#include <string.h>
#include <string>
#include <math.h>
#include <stdlib.h>
#include <queue>
#include <stack>
#include <set>
#include <map>
#include <list>
#include <iomanip>
#include <vector>
#pragma comment(linker, "/STACK:1024000000,1024000000")
#pragma warning(disable:4786)

using namespace std;

const int INF = 0x3f3f3f3f;
const int MAX = 1000 + 10;
const double eps = 1e-8;
const double PI = acos(-1.0);

int a[MAX];

int main()
{
int T;
while(~scanf("%d",&T))
{
while(T --)
{
memset(a , 0 , sizeof(a));
int ma = -INF , i , temp;
int n;
cin >> n;
while(n --)
{
scanf("%d",&temp);
a[temp] ++;
ma = max(ma , temp);
}
int MA = -INF;
int ans = 1;
for( i = 1;i <= ma;i ++)
{
if(MA < a[i])
{
MA = a[i];
ans = i;
}
}
int ans1 = 0;
for(i = 1;i <= ma;i ++)
if(MA == a[i])
ans1 ++;
if(ans1 == 1)
cout << ans << endl;
else
cout << "Nobody" << endl;
}
}
return 0;
}


View Code
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: 
相关文章推荐