您的位置:首页 > 其它

poj 2151 Check the difficulty of problems(概率dp)

2015-04-23 09:19 295 查看
题目链接

Check the difficulty of problems

Time Limit: 2000MSMemory Limit: 65536K
Total Submissions: 5482Accepted: 2414
Description
Organizing a programming contest is not an easy job. To avoid making the problems too difficult, the organizer usually expect the contest result satisfy the following two terms:

1. All of the teams solve at least one problem.

2. The champion (One of those teams that solve the most problems) solves at least a certain number of problems.

Now the organizer has studied out the contest problems, and through the result of preliminary contest, the organizer can estimate the probability that a certain team can successfully solve a certain problem.

Given the number of contest problems M, the number of teams T, and the number of problems N that the organizer expect the champion solve at least. We also assume that team i solves problem j with the probability Pij (1 <= i <= T, 1<= j <= M). Well, can you
calculate the probability that all of the teams solve at least one problem, and at the same time the champion team solves at least N problems?

Input
The input consists of several test cases. The first line of each test case contains three integers M (0 < M <= 30), T (1 < T <= 1000) and N (0 < N <= M). Each of the following T lines contains M floating-point numbers in the range
of [0,1]. In these T lines, the j-th number in the i-th line is just Pij. A test case of M = T = N = 0 indicates the end of input, and should not be processed.
Output
For each test case, please output the answer in a separate line. The result should be rounded to three digits after the decimal point.

Sample Input
2 2 2
0.9 0.9
1 0.9
0 0 0

Sample Output
0.972

题意:M道题目,T个人,已经每个人做出每道题目的概率,求所有人都过题,但是最多过N到题的概率。

题解:首先用dp[i][j][k]表示第i个人对于前j个题目,做出来k道题目的概率。通过这个dp我们先求出第i个人过j道题目的概率。然后再用f[i][j]表示前i个人,都过了题,最多过了j道题的概率。最后统计答案即可。

代码如下:

#include<stdio.h>
#include<iostream>
#include<algorithm>
#include<set>
#include<vector>
#include<string.h>
#include<map>
#define inff 0x3fffffff
#define nn 1100
#define mod 1000003
typedef __int64 LL;
typedef unsigned __int64 LLU;
using namespace std;
int m,t,n;
double p[nn][33];
double dp[nn][33][33];
double sum[nn][33];
double f[nn][33];
int main()
{
int i,j,k;
while(scanf("%d%d%d",&m,&t,&n)&&(m+t+n))
{
for(i=1;i<=t;i++)
{
for(j=1;j<=m;j++)
{
scanf("%lf",&p[i][j]);
}
}
memset(dp,0,sizeof(dp));
for(i=1;i<=t;i++)
{
dp[i][0][0]=1.0;
for(j=1;j<=m;j++)
{
for(k=0;k<=j;k++)
{
dp[i][j][k]+=dp[i][j-1][k]*(1-p[i][j]);
if(k>0)
dp[i][j][k]+=dp[i][j-1][k-1]*p[i][j];
}
}
}
for(i=1;i<=t;i++)
{
sum[i][0]=dp[i][m][0];
for(j=1;j<=m;j++)
{
sum[i][j]=sum[i][j-1]+dp[i][m][j];
}
}
memset(f,0,sizeof(f));
f[0][0]=1.0;
for(i=1;i<=t;i++)
{
for(j=1;j<=m;j++)
{
f[i][j]+=f[i-1][j]*(sum[i][j]-sum[i][0]);
for(k=0;k<j;k++)
{
f[i][j]+=f[i-1][k]*(sum[i][j]-sum[i][j-1]);
}
}
}
double ans=0;
for(i=n;i<=m;i++)
{
ans+=f[t][i];
}
printf("%.3lf\n",ans);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: