您的位置:首页 > 其它

【HDU 1016】Prime Ring Problem —— DFS

2015-04-17 19:25 288 查看
原题链接


Prime Ring Problem

Time Limit: 4000/2000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)

Total Submission(s): 31423    Accepted Submission(s): 13907


Problem Description

A ring is compose of n circles as shown in diagram. Put natural number 1, 2, ..., n into each circle separately, and the sum of numbers in two adjacent circles should be a prime.

Note: the number of first circle should always be 1.



 

Input

n (0 < n < 20).

 

Output

The output format is shown as sample below. Each row represents a series of circle numbers in the ring beginning from 1 clockwisely and anticlockwisely. The order of numbers must satisfy the above requirements. Print solutions in lexicographical order.

You are to write a program that completes above process.

Print a blank line after each case.

 

Sample Input

6
8

 

Sample Output

Case 1:
1 4 3 2 5 6
1 6 5 2 3 4

Case 2:
1 2 3 8 5 6 7 4
1 2 5 8 3 4 7 6
1 4 7 6 5 8 3 2
1 6 7 4 3 8 5 2

解题报告:

题目的意思是:一个n元环(1..n的一个排列),使得任意相邻的两个元素之和为素数,输出所有的可能(第一个位置只能为1)!

直接深搜(dfs)即可!

#include<cstdio>
#include<iostream>
using namespace std;

bool IsPrime[41]={0,0,1,1,0,1,0,1,0,0,0,
1,0,1,0,0,0,1,0,1,0,
0,0,1,0,0,0,1,0,1,0,
1,0,0,0,0,0,1,0,0,0};
int a[21];
int n,cnt=0;

bool IsRepeat(int aa, int len){
int i;
for(i=1;i<len && aa!=a[i];++i);

return i!=len;
}

void dfs(int k){
if(k==n) {
if(IsPrime[ a[n-1]+a[0] ]){
printf("%d",a[0]);
for(int i=1;i<n;++i)
printf(" %d",a[i]);
printf("\n");
}
}
else{
for(int i=2;i<=n;++i){
if( IsPrime[ a[k-1]+i ] && !IsRepeat(i,k) )
{
a[k]=i; dfs(k+1);
}
}
}
}

int main(){
while( ~scanf("%d",&n) ){
printf("Case %d:\n",++cnt);
a[0]=1;
if(n==1) printf("1\n");
else     dfs(1);
printf("\n");
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签:  ACM dfs hdu