您的位置:首页 > 其它

PAT : 04-树5. Complete Binary Search Tree (30)

2015-04-07 23:38 411 查看
A Binary Search Tree (BST) is recursively defined as a binary tree which has the following properties:

The left subtree of a node contains only nodes with keys less than the node's key.

The right subtree of a node contains only nodes with keys greater than or equal to the node's key.

Both the left and right subtrees must also be binary search trees.

A Complete Binary Tree (CBT) is a tree that is completely filled, with the possible exception of the bottom level, which is filled from left to right.

Now given a sequence of distinct non-negative integer keys, a unique BST can be constructed if it is required that the tree must also be a CBT. You are supposed to output the level order traversal sequence of this BST.

Input Specification:

Each input file contains one test case. For each case, the first line contains a positive integer N (<=1000). Then N distinct non-negative integer keys are given in the next line. All the numbers in a line are separated by a space and are no greater than 2000.

Output Specification:

For each test case, print in one line the level order traversal sequence of the corresponding complete binary search tree. All the numbers in a line must be separated by a space, and there must be no extra space at the end of the line.
Sample Input:
10
1 2 3 4 5 6 7 8 9 0

Sample Output:
6 3 8 1 5 7 9 0 2 4

我认为是挺难的一道题,结果看到了这么一个代码...瞬间简单了。用到的知识是,搜索二叉树的中序遍历必定是有序的也么一个结论,因此只需把给出的数列排序,按照中序遍历的规则构造完全二叉树即可,用数组表示最为方便,而且也不会浪费内存,构造二叉树的函数运用了递归,非常高端,需要仔细想才能想明白

#include <stdio.h>
#include <stdlib.h>
#include <algorithm>

using namespace std;

int n, index;

void buildtree(int node[], int tree[], int root)
{
if(root <= n)	{

int lson = root << 1;
int rson = lson + 1;

buildtree(node, tree, lson);
tree[root] = node[index++];
buildtree(node, tree, rson);
}
}

int main()
{

scanf("%d", &n);
int *node = (int *) malloc (n * sizeof(int));
int *tree = (int *) malloc ((n+1) * sizeof(int));
int i;
for(i = 0; i < n ; i++)
scanf("%d", &node[i]);

sort(node, node+n);

index = 0;
buildtree(node, tree, 1);

for(i = 1; i < n; i++)
printf("%d ", tree[i]);
printf("%d\n", tree[i]);

return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: