您的位置:首页 > 产品设计 > UI/UE

HDU - 1047 - Integer Inquiry (大数高精度)

2015-03-12 23:16 387 查看


Integer Inquiry

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)

Total Submission(s): 13969 Accepted Submission(s): 3523



Problem Description

One of the first users of BIT's new supercomputer was Chip Diller. He extended his exploration of powers of 3 to go from 0 to 333 and he explored taking various sums of those numbers.

``This supercomputer is great,'' remarked Chip. ``I only wish Timothy were here to see these results.'' (Chip moved to a new apartment, once one became available on the third floor of the Lemon Sky apartments on Third Street.)



Input

The input will consist of at most 100 lines of text, each of which contains a single VeryLongInteger. Each VeryLongInteger will be 100 or fewer characters in length, and will only contain digits (no VeryLongInteger will be negative).

The final input line will contain a single zero on a line by itself.



Output

Your program should output the sum of the VeryLongIntegers given in the input.

This problem contains multiple test cases!

The first line of a multiple input is an integer N, then a blank line followed by N input blocks. Each input block is in the format indicated in the problem description. There is a blank line between input blocks.

The output format consists of N output blocks. There is a blank line between output blocks.



Sample Input

1

123456789012345678901234567890
123456789012345678901234567890
123456789012345678901234567890
0




Sample Output

370370367037037036703703703670




Source

East Central North America 1996



简单大数题。。

AC代码:

#include <cstdio>
#include <cstring>
#include <algorithm>
using namespace std;

char a[110];
int ans[110];
int tmp[110];

void fun(char a[], int tmp[]) {
	int len = strlen(a);
	for(int i = len - 1; i >= 0 ; i--) {
		tmp[len - 1 - i] = a[i] - '0';
	}
}

void add(int ans[], int tmp[]) {
	int up = 0;
	for(int i = 0; i < 110; i++) {
		int t = ans[i] + tmp[i] + up;
		ans[i] = t % 10;
		up = t / 10;
	}
}

void print(int ans[]) {
	int flag = 0;
	for(int i = 109; i >= 0; i--) {
		if(ans[i] > 0) {
			flag = 1;
			printf("%d", ans[i]);
		}
		else if(flag && ans[i] == 0) printf("0");
	}
	if(flag == 0) printf("0");
	printf("\n");
}

int main() {
	int n;
	scanf("%d", &n);
	while(n--) {
		scanf("%s", a);
		if(strcmp(a, "0") == 0) {		//没判断只有一个0的情况,无语的WA了2次╮(╯▽╰)╭ 
			printf("0\n");
			if(n) printf("\n");
			continue;
		}
		memset(ans, 0, sizeof(ans));
		fun(a, ans);
		
		while(1) {
			scanf("%s", a);
			if(strcmp(a, "0") == 0) break;
			memset(tmp, 0, sizeof(tmp));
			fun(a, tmp);
			add(ans, tmp);
		}
		print(ans);
		if(n) printf("\n");
	}
	return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: