您的位置:首页 > 其它

zoj 3699 单调队列

2015-03-11 23:21 288 查看
Dakar Rally

Time Limit: 2 Seconds      Memory Limit: 65536 KB


Description

The Dakar Rally is an annual Dakar Series rally raid type of off-road race, organized by the Amaury Sport Organization. The off-road endurance race consists of a series of routes. In different routes, the competitors cross dunes, mud, camel
grass, rocks, erg and so on.

Because of the various circumstances, the mileages consume of the car and the prices of gas vary from each other. Please help the competitors to minimize their payment on gas.

Assume that the car begins with an empty tank and each gas station has infinite gas. The racers need to finish all the routes in order as the test case descripts.


Input

There are multiple test cases. The first line of input contains an integer T (T ≤ 50) indicating the number of test cases. Then T test cases follow.

The first line of each case contains two integers: n -- amount of routes in the race; capacity -- the capacity of the tank.

The following n lines contain three integers each: mileagei -- the mileage of the ith route; consumei -- the mileage consume of the car in the ith route , which means the
number of gas unit the car consumes in 1 mile; pricei -- the price of unit gas in the gas station which locates at the beginning of the ith route.

All integers are positive and no more than 105.


Output

For each test case, print the minimal cost to finish all of the n routes. If it's impossible, print "Impossible" (without the quotes).


Sample Input

2
2 30
5 6 9
4 7 10
2 30
5 6 9
4 8 10


Sample Output

550
Impossible

#include <iostream>
#include <cstring>
#include <cstdio>
#include <deque>

using namespace std;

#define maxn 100005

struct Data
{
int m, c, p;

}a[maxn];

int tot[maxn];
int n, cap;

int main()
{
int t;
scanf("%d", &t);
while(t--){
scanf("%d %d", &n, &cap);

for(int i = 0; i < n; i++)
scanf("%d %d %d", &a[i].m, &a[i].c, &a[i].p);

deque<int> que;
memset(tot, 0, sizeof(tot));
long long ans = 0;
for(int i = 0; i < n; i++){
while(!que.empty() && a[que.back()].p >= a[i].p) que.pop_back();
que.push_back(i);

long long need = (long long)a[i].m*a[i].c;
if(need > cap){
ans = -1;
break;
}

int pos;
int cur_cap = 0, inc;
while(cur_cap < need && !que.empty()){
pos = que.front();
inc = min(need-cur_cap, (long long)cap-tot[pos]);
cur_cap += inc;
ans += (long long)inc*a[pos].p;
for(int j = pos; j <= i; j++)
tot[j] += inc;
if(tot[pos] == cap)
que.pop_front();
}

tot[i] = need;

}

if(ans == -1)
printf("Impossible\n");
else
cout << ans << endl;
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签:  单调队列