您的位置:首页 > 其它

POJ 题目1936 All in All(水题,暴力)

2015-02-24 17:37 429 查看
All in All

Time Limit: 1000MSMemory Limit: 30000K
Total Submissions: 28814Accepted: 11933
Description

You have devised a new encryption technique which encodes a message by inserting between its characters randomly generated strings in a clever way. Because of pending patent issues we will not discuss in detail how the strings are generated and inserted into
the original message. To validate your method, however, it is necessary to write a program that checks if the message is really encoded in the final string.

Given two strings s and t, you have to decide whether s is a subsequence of t, i.e. if you can remove characters from t such that the concatenation of the remaining characters is s.

Input

The input contains several testcases. Each is specified by two strings s, t of alphanumeric ASCII characters separated by whitespace.The length of s and t will no more than 100000.
Output

For each test case output "Yes", if s is a subsequence of t,otherwise output "No".
Sample Input
sequence subsequence
person compression
VERDI vivaVittorioEmanueleReDiItalia
caseDoesMatter CaseDoesMatter

Sample Output
Yes
No
Yes
No

Source

Ulm Local 2002

ac代码

#include<stdio.h>
#include<string.h>
char a[100005],b[100005];
int main()
{
while(scanf("%s%s",a,b)!=EOF)
{
int len1=strlen(a);
int len2=strlen(b);
int i,j,flag=0;
for(i=0,j=0;i<len1;i++)
{
for(;j<len2;j++)
{
if(a[i]==b[j])
{
if(i==len1-1)
flag=1;
break;
}
}
j++;
}
if(flag)
printf("Yes\n");
else
printf("No\n");
}
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: