您的位置:首页 > 其它

HDU 2602 Bone Collector

2015-02-18 16:20 260 查看


Font Size: ← →


Problem Description

Many years ago , in Teddy’s hometown there was a man who was called “Bone Collector”. This man like to collect varies of bones , such as dog’s , cow’s , also he went to the grave …

The bone collector had a big bag with a volume of V ,and along his trip of collecting there are a lot of bones , obviously , different bone has different value and different volume, now given the each bone’s value along his trip , can you calculate out the
maximum of the total value the bone collector can get ?




Input

The first line contain a integer T , the number of cases.

Followed by T cases , each case three lines , the first line contain two integer N , V, (N <= 1000 , V <= 1000 )representing the number of bones and the volume of his bag. And the second line contain N integers representing the value of each bone. The third
line contain N integers representing the volume of each bone.


Output

One integer per line representing the maximum of the total value (this number will be less than 231).


Sample Input

1
5 10
1 2 3 4 5
5 4 3 2 1



Sample Output

14
基础01背包问题

#include<stdio.h>

int main(){
    int v, t, n, i, j, max;
    int a[1005], b[1005];
    scanf("%d", &t);
    while (t--)
    {
        scanf("%d%d", &n, &v);
        for (i = 1; i <= n; i++) scanf("%d", &a[i]);
        for (i = 1; i <= n; i++) scanf("%d", &b[i]);
        int f[1005] = { 0 };
        for (i = 1; i <= n;i++)
            for (j = v; j >= b[i]; j--)
                f[j] = f[j] > f[j - b[i]] + a[i] ? f[j] : f[j - b[i]] + a[i];
        for (max = 0, i = 0; i <= v; i++)max = max < f[i] ? f[i] : max;
        printf("%d\n", max);
    }
    return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: